WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
File path limitation on Windows servers (3 posts)

  1. bahead
    Member
    Posted 1 year ago #

    This isn't a problem with the plug-in, just a limitation in using it on Windows servers that I thought I'd add here.

    There's a 250 character limit on the total file path on Windows systems. If your cache folder is already deep (e.g., c:/inetpub/sharedhosting/domainname_com/web/blog/wp-content/cache/supercache/www.domainname.com/blog/), and you use long permalinks (i.e. post titles), then WP Super Cache will fail to cache pages if they exceed the 250 limit.

    This can happen also if the temporary cache file name that PHP writes exceeds the limit (even if the final file name would not).

    The only option is to reduce the root path of the cache folder, or to avoid creating permalinks that are too long.

    If anyone has any ideas on how to get around this issue, I'd love to know.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Moogle Stiltzkin
    Member
    Posted 1 year ago #

    does this problem make it so that the website does not load ?

    i mean what are the effects of this error ? other than those extra long files not being cached.

  3. bahead
    Member
    Posted 1 year ago #

    No other impact other than that pages with file paths over 250 characters don't get cached. I really just posted the comment so that anyone using the plug-in on a Windows server who can't figure out why certain files aren't being cached has an explanation.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic