WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Expired pages not being removed (15 posts)

  1. forefront
    Member
    Posted 5 years ago #

    I've tried different cache settings for expiry etc and expired pages and cache or supercache are never removed.

    I set debug too and nothing was reported. I set the cache folder to chmod 777 recursively and no change.

    What else could I try doing?

    (on Hostgator shared server)

  2. mkopischke
    Member
    Posted 5 years ago #

    Same problem here: I am helping a friend migrate her blog to self hosted, have installed WP Super Cache on her Hostgator hosting account. It performs just fine, but expired cache files are never deleted.

    Running Super Cache 0.9 in half mode with mobile device support on, WP 2.7 installed in a subfolder (/wordpress) but responding to the domain root (http://rhetashan.name). Contact me if you need the PHP info or server config from Hostgator’s CPanel.

    I’d really like to resolve this as the current Super Cache implementation is the first cache to play nice with the mobile site plugins installed, and manually deleting is out as I need a set and forget solution in the long run (I’m not going to do high frequency maintenance, and she is only technically semi-savvy).

  3. forefront
    Member
    Posted 5 years ago #

    I'd add that this is not Hostgator-specific, same with other hosting cos. on which I run Super Cache.

    What determines how file are removed?

  4. forefront
    Member
    Posted 5 years ago #

    I did some testing.

    With WP Cache and Super Cache both enabled, expired files just pile up, never being deleted irrespective of when I set expiry time to.

    With the "HALF ON" option set (Super Cache Disabled, only legacy WP-Cache caching) the plugin works perfectly with files being cached and expired files being deleted.

    I did test switching "Disable file locking" on with no change to the above findings.

    Certainly on Dreamhost and Hostgator servers this is the problem I've seen...legacy cache works and expired files are removed, super cache works but expired files pile-up.

  5. Aaron D. Campbell
    Member
    Posted 5 years ago #

    I originally thought this was due to other problems on my host, but now that those are fixed, it seems that this is still and issue.

    I had to check the box in settings that says "Disable file locking. If you experience problems with mutex or file locks this may help but may cause increased server load." The *REALLY WEIRD* thing is that I added do_action('wp_cache_gc'); to a page template and it ran perfectly, cleaning up all my expired files, even without that box checked. However, adding wp_schedule_single_event(time() + 10 , 'wp_cache_gc') to that same template does NOT help the problem (still needs that box checked).

  6. drawab
    Member
    Posted 5 years ago #

    Well id like to add Mediatemple to the list of host having this problem where expired files are not deleted -

    Ive just enabled half-on - to see if the garbage collection picks up

  7. Rodeo98
    Member
    Posted 4 years ago #

    I'm on Hostgator and I don't have any issue. With Hostgator you are supposed to strictly maintain the files and folder perms to 644 and 755 respectively. So that could be the issue with those who are on Hostgator servers.

  8. evilnrj
    Member
    Posted 4 years ago #

    same problem here, it used to work, worked for nearly a year without any problems, then two days ago it stopped deleting the expired cached pages - quickly filling the server up :/

  9. Donncha O Caoimh
    Member
    Posted 4 years ago #

    I think this is related to the WordPress 2.9 release - the cron system is bust in it, and the plugin relies on that to do clean up. WordPress 2.9.1 should fix this.

  10. Wiki-Stars
    Member
    Posted 4 years ago #

    I use a WordPress 2.8 and i've the same probleme...

    is somebody know a way to manualy activate the flush with a cron ? (a true one from the server) ;o)

  11. musicmasteria
    Member
    Posted 4 years ago #

    So donncha, are you updating the plugin to fix this or are we SOL until wordpress comes out with version 2.9.1?

  12. Donncha O Caoimh
    Member
    Posted 4 years ago #

    No, I can't fix it because it's not a bug in the plugin, sorry. 2.9.1 will be out very soon though.

  13. evilnrj
    Member
    Posted 4 years ago #

    That's great news, i hoped my provider hadnt messed anything up xD Got kinda low disk space on my server so, without the deleting of expired pages it fills up in a half day ~

    *Waiting Patiently (or at least trying to) for 2.9.1*

    Great plugin btw, domo arigato ;)

  14. Integrati
    Member
    Posted 4 years ago #

    Hi All,

    running 2.9.1 for my site integrati.com.au just about to install the WP Super Cache!

    Wish me luck!

    Will let you know how I get o in atick.

    Happy Friday!

  15. Integrati
    Member
    Posted 4 years ago #

    Hmm, ok it is insatlled and I have a couple of issues.

    couple I can not write up but will fix first.

    Looking forward to the update with 2.9.1 it may fix a couple of my minor issues.

    Thank you, Donncha.

    Or Slanche as you lot say in the emerald isles?

    Gidday anyway mate!

    :-)

Topic Closed

This topic has been closed to new replies.

About this Topic