WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Exclude specific pages? (4 posts)

  1. LauraDaily
    Member
    Posted 1 year ago #

    Apologies if this has been answered elsewhere but I am a site owner with limited technical expertise and an IT guy who is unavailable. We have installed Super Cache on my website http://www.milehighonthecheap.com and it has helped with some sudden and unexplained CPU load spikes. For that I am grateful. However Super Cache is also caching a page called Daily Deals that pulls in data from another site and doesn't want to update or refresh every hour as it should. So this a.m. we discovered that the deals listed were 2 days old, even though the origin page is refreshed every 3 hours. I want to simply remove that page from caching but so far have only figured out how to not cache every page (the same way i told Super cache to not cache my feed). Is there a simple way to tell the plugin not to cache a specific page. Thanks for any assistance you can provide. The Plugin has helped us tremendously through some bad times, but I need to start caching all pages save a few to really get things in check so we don't spike again or, worse, crash.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    In your daily deals page define the constant DONOTCACHEPAGE and it won't be cached. You can also put the url into the rejected uri textbox in the advanced settings page.

  3. hcomerford
    Member
    Posted 1 year ago #

    Hi Donncha,

    Thanks for answering but I'm not quite clear on how to perform both;

    Where/how can I define the constant DONOTCACHEPAGE? I have one page that must not be cached...I know the URL but have no idea how to exclude it from cacheing.

    Additionally, there is no rejected url textbox in the advanced settings page; perhaps you were referring to an earlier version of the plug in?

    Thanks for any help you can provide.

    Best,

    Hugh

  4. omigosh
    Member
    Posted 1 year ago #

    Hi Hugh

    I found the Rejected URI box near the bottom of the Advanced settings page

    Click the settings menu in your Dashboard and find the Settings tab for SuperCache. Look for 'Accepted Filenames & Rejected URIs'

    It let me remove caching for my home page. Don't know if it will allow you to add in a specific URL but you will at least be able to remove the type of page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic