WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] error message: WARNING! is writable.Please make it readonly (21 posts)

  1. altoyes
    Member
    Posted 6 years ago #

    hi folks

    how do i make it read only?
    ie what settings should i use?
    766 ?
    755 ?
    744 ?

    WARNING! /home/name/public_html/mysite/ is writable. Please make it readonly after your page is generated as this is a security risk.

    thankyou for your time

  2. Mindshare Studios, Inc.
    Member
    Posted 6 years ago #

    same message here. what's the right setting?

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    444 should work.

  4. Mindshare Studios, Inc.
    Member
    Posted 6 years ago #

    nope - that results in a Forbidden 403 message.

  5. Darkpress
    Member
    Posted 6 years ago #

    Try 644.

  6. ellenico
    Member
    Posted 6 years ago #

    I have tried 644 and also that resulted for me in a Forbidden 403 message.

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Just use the lowest number that lets the site actually work. 744, 755, who knows? Depends on the host's configuration.

  8. beernews
    Member
    Posted 6 years ago #

    What exactly does turning off writeability for the main folder do? Will I still be able to update the site?

    Obvious noob here though I understand how to change the settings. Just not sure how making that warning change to read-only will affect my WordPress installation.

  9. altoyes
    Member
    Posted 6 years ago #

    i have disabled the super cache.
    and gone backto wp-cache.
    how are you all going with super cache?

  10. pyang
    Member
    Posted 6 years ago #

    Directories require the execute bit set to access what's inside. That's why you guys are seeing the 403 error when you try to access the directory.

    Correct settings should be 755.

  11. RaulTBC
    Member
    Posted 6 years ago #

    @pyang: the mode on my blog root is 755 but I am still getting the warning when I go to the super cache options page.

  12. Anonymous
    Unregistered
    Posted 6 years ago #

    I'm getting the warning too, with 755. What's weird is that the warning tells me to set it to... 755.

  13. Donncha O Caoimh
    Member
    Posted 6 years ago #

    I have a fix in trunk for this. Hopefully to be released soon.

  14. BlakkJakk
    Member
    Posted 6 years ago #

    Cool. Thought I was going crazy. I went to root even to check it out and my prem is set to 755. I noticed when I disabled write entirely (555) it was happy but given that 755 is recommend for a lot of plugins I figured that was running the risk of breaking something.

    So its just a bug then?

    P.S. Thankx for this plugin. It saves my site every day. ;)

  15. Donncha O Caoimh
    Member
    Posted 6 years ago #

    Yeah, a minor bug. Glad the plugin help!

  16. RaulTBC
    Member
    Posted 6 years ago #

    So does that mean the minor bug is the notification on the plugin admin page or is there a true vulnerability?

  17. Donncha O Caoimh
    Member
    Posted 6 years ago #

    In my opinion, it's a vulnerability. Unfortunately, sometimes the webserver runs as the same user account as the human user who runs the site. When this is the case, all files are writeable by the webserver and could possibly be overwritten if the site is hacked.

    Enough sites run like this that there's code in the plugin to stop the warning if the wp-content directory has 755 permissions and still writeable, but the problem of web server writeable files and directories remains.

  18. BlakkJakk
    Member
    Posted 6 years ago #

    Interesting. My 755 permissions was set to user: apache / group: apache. The warning goes away when I set to my admin user account/group.

    So isn't that opposite of what I should want. Isn't apache more secure than using my admin user?

  19. Donncha O Caoimh
    Member
    Posted 6 years ago #

    No, it's more secure if the directory is 755 and owned by admin.

  20. bulletproof
    Member
    Posted 6 years ago #

    I get that warning also while my wp-content is already 755. It actually started happening after i updated to the latest version of wp-supercache.

    I am glad to see though it is gonna get fixed. Thank you!

  21. youjustmademylist
    Member
    Posted 5 years ago #

    I'm getting the same error but I have no idea what all this 755 talk is all about. Can someone explain in detail where/how I make this change?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic