WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Error Message on After a Move to New Server (7 posts)

  1. Tranny
    Member
    Posted 2 years ago #

    I used to use WP Super Cache for several years. Few days ago I moved onto a different dedicated server with different host and have been completely unable to get the plugin to work. The error I get is:

    Your cache directory () did not exist and couldn’t be created by the web server. Check permissions.
    Cannot continue... fix previous problems and retry

    Since I've been trying to get this resolved for days and spent lots of money on server techs who said they would resolve it but none did, I found that the way to by pass this error is by manually creating the /cache/ subdirectory in wp-config directory. That eliminates the error message, however caching still does not work. Files are created inside the folder, but none of the folder tree for each of the categories and posts within it are created. As a result, when I go to the Contests tab of the plugin settings, it constantly shows that 0 pages are cached and/or supercached (even after regeneration of stats).

    Similarly, testing the cache on Easy tab returns a message that time stamps either could not be read or did not match. I've run out of all of my options and the last resort was to ask for help here. If I'm unable to resolve it, I'll have to give different caching plugin a try cause my DB server is getting hammered (it's a very high traffic blog I run). Anyone able and willing to offer input as to what I can do to get WP Super Cache to work?

    Thank you :/

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    View the source of any page on your site and it'll probably have a message saying it couldn't write to that cache directory. FTP to your server and change the ownership so wp-content/cache is world writeable. That'll fix the problem.

  3. Tranny
    Member
    Posted 2 years ago #

    Hello Donncha,

    thank you for speedy response. You are right about the message. It does say at the bottom that "File not cached! Super Cache Couldn't write to: wp-content/cache/supercache/www...."

    I did CHMOD /cache/ to 777 and it is still 777. It has been 777 this whole time. I also made sure wp-content is 777 when I was activating the plugin but it continues being unable to write in it. Is this what you mean by changing ownership so it is world writeable? Or is there something more I need to do? 777 on its own still prevents the script from working properly.

  4. Tranny
    Member
    Posted 2 years ago #

    The problem persists big time, even with everything set to 777. If I create /cache subdirectory manually, it doesn't help because script still can't write inside of it.

    From the error log:

    msgid "Your cache directory (<strong>$cache_path</strong>) did not exist and couldn’t be created by the web server. Check %s permissions."

    What is %s? Is it a username?

  5. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Do you have a line in wp-content/wp-cache-config.php that defines the variable $cache_path?

    If you can, delete wp-content/wp-cache-config.php as there's something gone wrong in there (I think).

  6. Tranny
    Member
    Posted 2 years ago #

    Hello Doncha,

    you have the best support for a plugin on WP. I appreciate you staying dedicated to help no matter what. It turned up being an issue with mkdir being disabled which prevented script from writing directories to folders. I went through hell and back to figure it out and it drove me insane and at the end of the day it was a stoopid server side restriction.

    I appreciate your help,

    Mark

  7. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Wow, that is a really weird and odd server you're on there! Glad you figured it out though!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic