WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Erroneous Garbage Collection warning (7 posts)

  1. mvandemar
    Member
    Posted 1 year ago #

    I just installed the new WP Super Cache on a client's site, activated it, enabled it, and am getting this warning (which occurred before I updated the .htaccess rules and is still there after:

    Warning! Garbage collection is not scheduled!

    It was defaulting to collect at 00:00 hours, I switched it to 3600 minutes and the error is still showing. There is an option there to dismiss it but I don't want to dismiss it if garbage collection actually is disabled at this point.

    Thoughts? Anyone else having this same issue?

    -Michael

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Abhishek Ghosh
    Member
    Posted 1 year ago #

    Yeap, on Rackspace Cloud Sites.
    Probably it is a bug, as I use Preloading, it is not much headache for me (GC will not work).
    Unfortunately none the dependent plugins like WP Minify or CDN Sync Tool are working.

    Check the cache folder and log files for any error. I got no error.

  3. chadrew
    Member
    Posted 1 year ago #

    I also had this error after upgrading to the new version, but then I re-saved the garbage collection options, and it went away. Everything seems to be working fine.

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    @mvandemar - garbage collection isn't running then. Use the cron view plugin to see what is scheduled. Might be something odd on your site, perhaps another plugin?

    http://wordpress.org/extend/plugins/cron-view/

  5. Lumpysimon
    Member
    Posted 1 year ago #

    I'm also seeing this warning message since upgrading - it is directing me to the preload options page, but I don't want to use preloading.

    I checked the garbage collection options on the advanced page and it was set to check hourly from 00:00, so I'm not clear if this is not happening or if it's just the logic to display the warning that is wrong. I changed this setting to an interval of every 7200 seconds and the warning went away.

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    @Lumpysimon - if you never touched the Garbage collection settings they weren't activated. Unfortunately until now this wasn't clear.

  7. Lumpysimon
    Member
    Posted 1 year ago #

    aha! thanks for the clarification.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic