WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Plugin: WP Super Cache: Does it work without mod_header and mod_deflate (16 posts)

  1. LifeAtTheCircus
    Member
    Posted 5 years ago #

    I am using a web hosting service that does not have mod_deflate or mod_headers loaded. I have talked to them about it and they will not activate them for me. I can make a .htaccess file but anything in an <ifmodule> that calls out these modules will not be run.

    So, should I bother using WP Super Cache? I notice that one of the main things it does is modify/create and .htaccess file which is mostly meaningless to my server given its limitations (not the fault of the plugin of course). Anyway, should I activate the plugin or, without Apache modules loaded is it not constructive.

    Note: I also have a slight problem where it, when active, does not allow anything other then the main page to load with IE7. I am not necessary asking for troubleshooting support on that yet, I first want to know that the plugin is going to work with my lame hosting service.

  2. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Use the plugin in "half-on" mode. There's negligible difference for normal traffic.

  3. LifeAtTheCircus
    Member
    Posted 5 years ago #

    Thanks so much Donncha. I have done what you said and feel much better hearing from you of all people that it is still a helpful plugin given my situation.

    Unfortunately, I had to turn off the plugin because of the IE7 problem I alluded too. I still have some troubleshooting to do on my own before I pester the forum with details (like disabling all other plugins and making sure there is no obvious conflict). However, if anyone knows of what the IE7 problem is before I formalize a thread about it, feel free to steer me in the right direction.

    Thanks again.

  4. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Did you have IE7 problems in half-on mode?

  5. LifeAtTheCircus
    Member
    Posted 5 years ago #

    Thank you so much for your interest in my problem. Yes, the problem occurs even when in half-on mode. I have no problem using FF, IE6, Chrome, and even PC based Safari but IE7 fails in the worst way. It does not just give me a 404 error. Rather. Explorer comes up with the window:
    *******************************
    Internet Explorer cannot display the webpage

    Most likely causes:
    You are not connected to the Internet.
    The website is encountering problems.
    There might be a typing error in the address.
    ********************************

    Please note the the browser has no problem with the plugin in off mode. Any ideas?

    I should note, near the bottom of my page source there is the following code:

    <!--[if lte IE 7]>
    <div id="ie_clear"></div>
    <![endif]-->

    This code is added by my template and I am not sure why it is there. Perhaps it is part of the problem (though I doubt it because when caching is not active the page loads find and, as I understand caching, the cached page should just be a copy with the same source). Any thoughts? I recognize that the time you choose to put into this may be limited since it does not appear to be a common issue within this forum. I'm not sure why that is however because I can't imagine there is anything all that special about my blog apart from the absence of the modules I noted at the beginning of this thread.

    Thanks again for any of your time you can offer. If you are so inclined, the site address is http://<enter my login name as it appears to the left>.com. Right now wp_supercache is deactivated because of the IE7 issue but I would be willing to turn it on for a time if anyone requested it.

  6. LifeAtTheCircus
    Member
    Posted 5 years ago #

    I have isolated the problem. There appears to be a conflict between the WP Super Cache and PHP Speedy Plugins. They can work together so long as you don't select the "gzip page" option in PHP_Speedy. This is really too bad since, given my inability to have mod_deflate do server side compression, it means I get no compression of my .html page. Thankfully though, they both seem to play nice together when the "gzip js" and "gzip css" are selected. At least something gets compressed.
    It should also be noted then when "gzip page" is selected, the serving of the cache WP cache file is unreliable (i.e. it does not cause pc based Safari to break but Safari does not get the cached file either.). All this to say, while it is not the responsibility of plugin authors to accommodate each other, it may be worth mentioning this in the troubleshooting section of your next release since both plugins deal with site optimization and therefore it would not be unheard of for them both to be loaded by your plugin users. Without this warning, you would have no knowledge of this really bad problem if they don't test IE7.

    Note: I did all my testing in half-on mode and thus I cannot comment on performance or conflicts when in "on" mode.
    Note2: If your sever does compression, you are unlikely to have "gzip page" selected anyway and you will never see this problem.

    Thanks for your time donncha. I just donated to your login to "put my money where my mouth is" w.r.t. this plugin and your support of it.

  7. Donncha O Caoimh
    Member
    Posted 5 years ago #

    LifeAtTheCircus - thanks for investigating! I wonder if other users with the IE7 problem have PHP Speedy installed too?

    I'll check out that plugin and debug it. It should be simple enough to disable that option in the plugin if supercache compression is enabled. All you need is compression in one place after all!

  8. Donncha O Caoimh
    Member
    Posted 5 years ago #

    I just checked php speedy and in the latest version the gzip page option doesn't do anything. It used to set gzipcompression to 1 so that WordPress compresses the page but that doesn't happen any more.

    I tried php speedy on all sorts of settings but in IE7 kept getting an error about Lightbox not finding it's script tag or something. It did load in IE 7 every time but once when a reload loaded the blog fine.

  9. LifeAtTheCircus
    Member
    Posted 5 years ago #

    A few followup questions:
    - Do you still suggest I use "half-on" mode? Had you suggested it because I didn’t have mod_deflate and mod_headers (still true) or because of the IE7 problem (now avoided)? (I currently have "on" mode selected and I think it is working...)

    - WP_Supercache offers the "compression" option only when in full "on" mode. Assuming you change your recommendation w.r.t. supercache "on" mode, will there be a benefit to selecting the compression option you offer in the "wp_supercache" plugin (remember, I still won't have have mod_deflate)? If using your compression option, should I then un-check the "gzip js" and "gzip css" options in php_speedy? (I currently do not have supercache compression selected.)

  10. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Yes, you should use half-on mode otherwise your visitors will see really old pages, and possibly garbage on their screens.

    The plugin compresses in half-on mode automatically depending on whether the browser supports it. I don't honestly know if the gzip js and css options will conflict with anything else. sorry!

  11. LifeAtTheCircus
    Member
    Posted 5 years ago #

    Thanks for all your help. I just saw that I can log threads as "resolved" and am going to do that. Firebug says my html does not compress but I guess that will have to be ok. It is just a "mom blog".

    A summary for those that find this via search engines over time...

    - If you don't have mod_deflate and mod_headers available, run WP super cache (v.0.9.4.3) in half "on mode"

    - If you use the PHP_speedy plugin (v.0.5.2) with the WP_super_cache plugin, make sure you do not select the "gzip_page" option. (the gzip_js and gsip_css options are ok and do work). If you do select gzip_page, it may appear to work in your browser but some of your IE7 users might be getting a bad error.

    If you have questions about these summary bullets, read the thread.

  12. Donncha O Caoimh
    Member
    Posted 5 years ago #

    LifeAtTheCircus - your summary is slightly incorrect.

    1. The latest version of php speedy doesn't do anything when you enable page gzip. No point in disabling it or not. You might be using an old version.
    2. You can use the plugin in ON mode with static files without mod_deflate installed. I recommend not using that Apache module anyway because the gzipped content isn't cached and is gzipped every request.
    You are right to use the plugin in half on mode if you don't have mod_headers.

  13. Ed
    Member
    Posted 5 years ago #

    I've been trying to find a way to get the newest versions of phpSpeedy and SuperCache to work together, finally it works. Now my only problem is not being able to gzip the page, everything else is compressed. Is there a way to compress just the page using .htaccess or some other way without wrecking these plugins? Every time I try mod deflate etc in my .htaccess I get a 500 error. Websites http://www.ec-comp.com if you want to check.
    Cheers!

  14. Kynes
    Member
    Posted 5 years ago #

    Coopeh, how did you meke them both work at the same time?

    I couldn't make it myself.

  15. Ed
    Member
    Posted 5 years ago #

    Kynes - As far as I remember, because I'm not using SuperCache anymore due to underusage of my site, all I did was set SuperCache to Half on so it wasn't gzipping the output and turn page gzip off in phpspeedy. This means your webpage will be slightly larger as you can't enable gzipping on either plugin, but they did work together bar that.

  16. aaronpearson
    Member
    Posted 4 years ago #

    I had to remove the php invocation of gzip from the header.php file of my theme. I had put ob_start("ob_gzhandler"); Other wise IE7 wouldn't display the webpage.

Topic Closed

This topic has been closed to new replies.

About this Topic