WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: WP Super Cache] difference in .htaccess rules message (7 posts)

  1. RavanH
    Member
    Posted 4 years ago #

    Testing SuperCache 0.9.9.2 in WP 3.0-RC3 in MultiSite mode, it seems to be working fine (so far, only tested on one site) but I keep getting a message on both the pages Super Admin > WP Super Cache and Settings > WP Super Cache (is there any difference between the two anyway?) :

    A difference between the rules in your .htaccess file and the plugin rewrite rules has been found. This could be simple whitespace differences but you should compare the rules in the file with those below as soon as possible. Click the ’Update Mod_Rewrite Rules’ button to update the rules.

    I checked both .htaccess files and copy pasted the rules again to be sure but the message remains.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. RavanH
    Member
    Posted 4 years ago #

    Oh... and there is no ’Update Mod_Rewrite Rules’ button even if the htaccess files are writable ;)

  3. RavanH
    Member
    Posted 4 years ago #

    And another warning message that seems persistent whatever I do :

    Warning! You must make /hermes/bosweb/web109/b1091/ipg.aufildudouxcom/4visions.nl/ writable to enable this feature. As this is a security risk please make it readonly after your page is generated.

    The dir rights are 755. Not good?

  4. Donncha O Caoimh
    Member
    Posted 4 years ago #

    I think you're the first person to try the multisite feature with the plugin! I guess none of the testers had that enabled.

    755 is fine, but the directory isn't owned by the webserver or php so that's why they can't write there. You'll have to temporarily change it to 777 but change it back after things are set up.

  5. RavanH
    Member
    Posted 4 years ago #

    I see. No problem.

    Another thought on SuperCache in MultiSite environment: I notice that in Hashcash activated Network Wide, there is only one Super Admin > WordPress Hashcash settings page. It probably is just a cosmetic thing but maybe that would be a nice idea to implement such behaviour in SuperCache too?

  6. Donncha O Caoimh
    Member
    Posted 4 years ago #

    I've just updated the development version. The zip file on the download page should update in the next 15 minutes or grab wp-cache.php and put it in your plugins/wp-super-cache/ directory.

  7. RavanH
    Member
    Posted 4 years ago #

    Ok, so I press the ’Update Mod_Rewrite Rules’ button and I get to see a very weird page content after it has reloaded. The WP top bar and menu are there and even the footer but the content seems empty except for all the way in the middle (have to scroll for it) what appears to be the end of some of those long lines that are in the rewrite rules.

    My guess is that my browser (Opera) fills the content but 'scrolls' it to the left out of sight only to show the end of those 4 very long lines... Maybe if you wrap the message with the rewrite rules in a div with fixed width/height and overfloat:none and scroll:auto or something? Or even < code > tags might help in light of already supported HTML5 in that browser ;)

    Anyway, got me scared there a bit but after reloading the page, all was well again and no more message about a detected difference in rules :)

    THANKS !

Topic Closed

This topic has been closed to new replies.

About this Topic