WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Deleting comment doesn't reset cache for page (it should!) (21 posts)

  1. Fakey
    Member
    Posted 5 years ago #

    donncha,

    When a comment is deleted the cache should be cleared for that page (so the comment actually disappears). As it is now, a comment is deleted, then you have to manually clear the entire cache just so one page will reflect the changes.

    Kinda crummy.

    But, great work otherwise.

  2. qdinar
    Member
    Posted 5 years ago #

    (this question appeared in my mind:)
    what does super cache if manually delete corresponding file for that page?

  3. Donncha O Caoimh
    Member
    Posted 5 years ago #

    wyDay - I presume you have the "do not cache for logged in users" activated? Grab the development version. It should be fixed now.

  4. ljmac
    Member
    Posted 5 years ago #

    I've just tried out 0.9.4.2, and now when comments are added, the pages aren't updated! This has never been a problem for me before - note that I run it in "half on" mode, which means everything should update (and in the case of previous versions, it did).

    Looks like your fix broke something else!

  5. Donncha O Caoimh
    Member
    Posted 5 years ago #

    ljmac - do you have the "do not cache for logged in users" activated? Were you viewing the page as a logged in user or not?

    I tested on my own blog and the page updated after I left a comment, with or without the "do not cache" option set.

  6. ljmac
    Member
    Posted 5 years ago #

    I don't even see this option! Is it only for Super Cache mode? I was logged in at the time.

    Once again, it worked fine with all previous versions. In half on mode, the pages always updated instantly, whether I was logged in or not.

  7. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Install the plugin again. Maybe when you upgraded it wasn't done correctly.

  8. stratosg
    Member
    Posted 5 years ago #

    I have the exact same problem. When a commenter leaves a comment (even me!) the cache is not refreshed. It has to either expire or be manually deleted. It hasn't been an issue for me either before except since the last update. Do you have any idea of what's happening? Have you confirmed the problem?

  9. Donncha O Caoimh
    Member
    Posted 5 years ago #

    stratosg - can you copy wp-super-cache/wp-cache-phase2.php off your server and upload it to pastebin.com and post the url here please?

    I need to compare files. Thanks.

  10. stratosg
    Member
    Posted 5 years ago #

    Certainly! There you go http://pastebin.com/m6e0c7997

    Thanks for the immediate reply and let me know if you need anything else...

  11. Donncha O Caoimh
    Member
    Posted 5 years ago #

    stratosg - do you have file locking enabled? If so add this line at line 9 in wp-cache-phase2.php and remove it from line 45. Does that help?

    wp_cache_mutex_init();

    Or just disable file locking.

  12. stratosg
    Member
    Posted 5 years ago #

    This seems to have removed the problem! I don't remember enabling this option but anyways thanks a lot for toubleshooting with me Donncha!

  13. ljmac
    Member
    Posted 5 years ago #

    So simply disabling file locking fixes this? Mind you, I would prefer to leave it enabled though - it was working fine in previous versions after all.

  14. Donncha O Caoimh
    Member
    Posted 5 years ago #

    ljmac - disabling file locking or fixing the bug above. The file locking is really not needed any more though.

  15. ljmac
    Member
    Posted 5 years ago #

    I take it the bug fix will find its way into the next version? If so I might just play it safe and wait for that.

  16. Donncha O Caoimh
    Member
    Posted 5 years ago #

    ljmac - *sigh* yes it will make it into the next version but it would be *really* nice if I had confirmation from more than one other person that this fix really worked.

  17. ljmac
    Member
    Posted 5 years ago #

    I downloaded it again to test this out, and I see you've already added this fix. And I can confirm that it does work!

  18. Donncha O Caoimh
    Member
    Posted 5 years ago #

    ljmac - thanks! Appreciate the feedback!

  19. ljmac
    Member
    Posted 5 years ago #

    Thanks for fixing it so quickly!

    BTW, the reason I didn't see the "do not cache for logged in users" option was because I'd reverted to an earlier version of course - it's there now!

    FYI, I have it disabled, as I prefer to see what happens for all users.

  20. nikesalelin
    Member
    Posted 5 years ago #

    why,ljmac - disabling file locking or fixing the bug above. The file locking is really not needed any more though.

    ----------------------------------------------------------
    --------------------------------------------------------

    Our website: http://www.nikesalesite.com
    MSN: nikesalelin@hotmail.com
    SELL Cheap Brand hoodies,bags,sneakers

  21. ljmac
    Member
    Posted 5 years ago #

    I'm not entirley sure what you're actually asking, but Donncha has fixed this bug in the latest version - it does work with file locking now.

    What I have disabled is the "do not cache for logged in users" option, so I can see for myself what happens for all users.

Topic Closed

This topic has been closed to new replies.

About this Topic