WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Delete Cache Button Problem (28 posts)

  1. mastertrc
    Member
    Posted 2 years ago #

    Hello

    Today i have updated my wp superchache plugin with 1.0 version.

    Plugin updated succesfully and when i try to use Delete Cache button i saw only "WP-Super-Cache" files deleted but "WP-Cache" files still on there and i did try everything (reinstall, deactivate-activate) but i didnt solve this problem.

    How can i fix this problem?

    Thanks

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    If that's the "Delete Cache" button on the admin bar then that's the expected behaviour. It only deletes the supercache files for the current page.

  3. alexter
    Member
    Posted 2 years ago #

    Same problem here with the main "Delete Cache" button in the Contents tab of plugin configuration (not just the admin bar)

    The only way to clear WP-Cache is to disable and re-enable compression. Going back to 0.9.9 fixes the problem

  4. dikkevandale
    Member
    Posted 2 years ago #

    Where can I download 0.9.9? I have exactly the same problem...

  5. mastertrc
    Member
    Posted 2 years ago #

    Its main "Delete Cache" button under settings (Contents tab)!

  6. pixeline
    Member
    Posted 2 years ago #

    Same here.

  7. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    I think I know what the problem is. Those are wp-cache files placed there by the previous version of the plugin. To make things scale better those files are now placed in a blogs/blogurl.tld/ directory. On a multisite site you also have a "Delete Cache on all Blogs" button on that page which deletes those files and everything in the cache directory but unfortunately it's not available on a single blog system.

    This problem will be fixed, but be assured that the cache is getting deleted, even if you can see them in the wp-content/cache/ directory.

  8. dikkevandale
    Member
    Posted 2 years ago #

    @Donncha:

    I had no previous version of the plugin installed. It's the first time I installed a cache plugin on this website... :D

  9. alexter
    Member
    Posted 2 years ago #

    My frontpage was not updated until I disabled the cache so "but be assured that the cache is getting deleted" is not quite true in my case

  10. G
    Member
    Posted 2 years ago #

    same here Donncha, i upgraded and "Delete Cache" no longer does the job - i go into cache directory by ftp to delete the still existant files - on a MU setup.

  11. G
    Member
    Posted 2 years ago #

    i reverted back to version 0.999 as it deletes cache properly. i also had a problem with some css files working properly on new version.

  12. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    The development version has a fix for this. It's on the same page as the previous version.

  13. pixeline
    Member
    Posted 2 years ago #

    Donncha,
    Just wanted to say thanks for your hard work on this super useful plugin. The tone of some comments here make me feel that a few people seem to forget you are giving a lot of your time for this plugin and for free.
    Cheers,
    a.

  14. alexter
    Member
    Posted 2 years ago #

    Donncha, thanks for your efforts.

  15. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks, both of you. This weekend especially has been stressful!

  16. deljo
    Member
    Posted 2 years ago #

    Replace all the old version until the new version is not completely functional. Do not bother man.

    regards

  17. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    deljo - you're obviously not reading the threads. There's a fix for this in the development version: wp-super-cache.zip

  18. technabob
    Member
    Posted 2 years ago #

    What's the easiest way to upgrade to the development version? I'm used to using the built in WordPress upgrader. Or should I just wait for the update release to come out? Donncha, any idea when that might be?

    Oh, and I second what has already been said - thanks for all your work on this plugin - you've made millions of sites much faster.

  19. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Download the zip file, unzip it and then upload the directory wp-super-cache to your wp-content/plugins/ directory. It should overwrite the directory of the same name there.

  20. technabob
    Member
    Posted 2 years ago #

    I installed the update, but even when I clear cache, I'm still seeing cached files under the "WP-Cache" section in the interface. Expired pages are clearing properly though. Is this normal behavior?

  21. echezuria
    Member
    Posted 2 years ago #

    The problem persist on the development version too. I just upload and overwrite the plugin files with the development version and it is still not deleting the WP-Cache files when I click the delete cache button.

    Please could you fix this? or should we download de 0.9.9.9 version?

  22. pixeline
    Member
    Posted 2 years ago #

    @echezuria: are you absolutely sure that :
    - the cache and inside content is chmoded 777
    via ssh:
    chmod -R user:user wp-content/cache/*

    - php user has proper rights?
    via ssh (replace "user with the proper owner in your system): chown -R user:user wp-content/cache/*

    Try deleting afterwards via WP Super Cache.

    If that doesn't work, try deleting the cache manually via FTP and then observe if the plugin is able to delete the new cache files, because the faulty cache may have been created with a previous version of Super Cache which lacked proper rights. That's what happened to me: upgrading to the latest Super Cache + deleting the old cache to start afresh solved it. Runs smooth now!

  23. dikkevandale
    Member
    Posted 2 years ago #

    @pixeline, that was my solution. Thanks!

  24. JustinHorn
    Member
    Posted 2 years ago #

    I've noticed that the main delete button only clears the super cache files. I've been able to delete the regular cache one by one, by looking in the list view.

    Although, sometimes some regular cache files will not delete this way either and I have to do it from FTP / SSH.

    UPDATE: The manual delete not working, might have just been because there was a spammer hitting the same pages over and over. Since I deleted that account and blocked their IP I can delete all the regular cache files manually.

  25. echezuria
    Member
    Posted 2 years ago #

    @pixeline, I just tried what you said with chmod command via ssh, but it is still not deleting the regular cache. Also I delete manually the old cache files, but it didn't work anyway.

  26. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    This is fixed in the dev version. The zip file will update in about 15 minutes.

  27. echezuria
    Member
    Posted 2 years ago #

    Thanks a lot Donncha, I just download the dev version and it is working fine.

  28. magonzalez987
    Member
    Posted 2 years ago #

    tried
    Compress pages so they’re served more quickly to visitors. (Recommended)

    on and off

    save settings doesnt work keeps hanging

    also clicked on contents, and clicked delete cache and browser hangs.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic