WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Deactivating WP Super cache resolved Blog 404 issue (7 posts)

  1. KennyThemap
    Member
    Posted 2 years ago #

    An issue that occurred recently for a number of WP users was that suddenly links, inlcuding menu links, to their Blog page resulted in an Error 404 page. The thread is here.

    I, like some others, thought it to be connected to the recent WP upgrade. Maybe it is indirectly but I tired of waiting so started a program of plugin dactivations this morning. The very first one being WP Super Cache, resolved the issue.

    I have suggested in the thread above that other users report back on whether deactivating WP Super cahe resolved the issue for them so you can get a handle on the extent of the issue.

    Kenny

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. admintiger
    Member
    Posted 2 years ago #

    WP Super Cache 1.1 works fine here with WP 3.4 under both Windows and Linux using Apache web servers configured for dedicated or name-based virtual hosting. Are you using Apache?

  3. KennyThemap
    Member
    Posted 2 years ago #

    Apache / Linux. Host is DigitalPacific.com.au if you wish further info.

    I have bot said that the Error 404 is solely due to the combo of 3.4.1 and WP Super Cache. Hence my suggestion of finding the extent of this solution for those who have reported the issue.

    I am not a techo so have reported what worked for me plus my suggestion for gathering further info. I'll leave it to others better equipped to suss out the ins and outs of the issue.

    Over and out unless I can help further.

  4. admintiger
    Member
    Posted 2 years ago #

    Are the 404 errors due to link URLs being wrong or due to linked pages not being available? In other words, do the pages being linked to display without errors if you type their URLs in a web browser address bar instead of taking a link from another page?

  5. KennyThemap
    Member
    Posted 2 years ago #

    Due to the linked page not being available. It was just the main blog page. The links to categories and posts that showed up on the 404 page worked well.

  6. admintiger
    Member
    Posted 2 years ago #

    I don't have that problem here with any of multiple installations. It might be a Permalink issue. I use a "/%post_id%/%postname%/" custom Permalink structure that likely is different than what you are using. I suggest that you go to Settings/Permalinks and simply click the "Save Changes" button which can fix Permalinks under certain circumstances.

  7. KennyThemap
    Member
    Posted 2 years ago #

    As I had already deactivated WP Super cache I had to activate it again to try your idea. However, in activating it I was presented with all the setup tabs and noted that the settings were considerably different to what I had previously set. (Maybe they are the default settings). I would have thought that deactivating would not affect settings.

    Anyway after setting up again, my Blog links still work.

    Still going at the end of the day. I'll leave it there unless it reoccurs.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic