WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Could not get mutex lock (5 posts)

  1. giacgbj
    Member
    Posted 5 years ago #

    At the end of any page I see
    <!-- Page not cached by WP Super Cache. Could not get mutex lock. -->

    I've already tried to edit wp-content/wp-cache-config.php and uncomment "$use_flock = true" or set $sem_id to a different value, but nothing works.

    Do you have any idea?

  2. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Anything in your error log? What happens when you try $use_flock?

  3. giacgbj
    Member
    Posted 5 years ago #

    If you mean the error log of Apache, I just can't see it because my host doesn't allow to access that logs :/. If I set that variable nothing changes.

  4. Donncha O Caoimh
    Member
    Posted 5 years ago #

    You should talk to your host then. The mutex flag is used to make sure file locking works correctly. Otherwise you could get corrupted cache files or "race conditions".

  5. rajupp
    Member
    Posted 5 years ago #

    Absolutely same problem here.
    Apache error log says -
    "[Sat Jan 03 11:06:40 2009] [error] [client 66.150.96.121] PHP Warning: filesize() [function.filesize]: stat failed for /home/xxxx/public_html/wp-content/cache/wp-cache-a3b8952813033977a26416392d3d768d.html in /home/xxxxx/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 464"

    Line 464 says-
    "array_push($wp_cache_meta_object->headers, 'Content-Length: ' . filesize( $cache_path . $cache_filename ));"

    No idea what to do.

Topic Closed

This topic has been closed to new replies.

About this Topic