WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
- Clear Cache after post edit? (12 posts)

  1. tyler durden
    Member
    Posted 4 years ago #

    Hi,

    I love this plugin but am disappointed that the plugin doesn't force a clearing of cache when I edit an existing post. Is there a configuration option to make this happen?

    Many thanks

    Andrew

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    Yeah, "Clear all cache files when a post or page is published. (This may significantly slow down saving of posts.)" on the admin page.

  3. qdinar
    Member
    Posted 4 years ago #

    please make possible to clear only one

  4. tyler durden
    Member
    Posted 4 years ago #

    @ donncha - thank you but that doesn't work. The cache clears when I add a new post but not when I edit an existing post.

  5. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    The plugin should clear the cached files for an existing post when edited. Try the debug system in the plugin if you're experiencing problems. It may help you debug the problem.

  6. qdinar
    Member
    Posted 4 years ago #

    i have just now tested it with httpfox from another firefox profile. it clears correctly: [one corresponding] page and front page after edit and after adding comment. i have not checked pages of list of posts by category and tag, and "pages".
    for case that somebody wants to test: it updates front page even if change is after more tag and change is invisible on front page, take in account that theme may show full post on front page or last edited time. also it updates front page if comment is added, remember that comment count is shown on front page.

  7. idagency
    Member
    Posted 4 years ago #

    Hi,

    Thx for answer, this option was enabled but however, the cache is not clear when i add a post.

    Same when i edit. I have enabled debug mode in the plugin page, is it supposed to send me results of the debugging stage ?

    Thx.

  8. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    idagency - it logs to a file or emails them to you. Logging to a file is better IMO.

  9. qdinar
    Member
    Posted 4 years ago #

    indeed it can do not work, now it does not update files at my installation, and does not create gz files at all ie even first time.

  10. qdinar
    Member
    Posted 4 years ago #

    i think not updating is because after adding comment user is redirected to http://wp.localhost/2010/08/09/комп/comment-page-1/ and it is not updated, only http://wp.localhost/2010/08/09/комп/ . this is with kubrick (home) theme.
    ... i add after a minute: no, http://wp.localhost/2010/08/09/комп/ is also not updated.
    i add after several minutes: i think it can be because i now have enabled wpml multilingual plugin.
    i add after 10-20 minutes: it seems it is related to slug with cyrillic letters, and i have modified wp-super cache for cyrillic slugs work.

  11. qdinar
    Member
    Posted 4 years ago #

    gzipping just was disabled. btw why not enable it by default?

    i add after several minutes:
    i think this is related to cyrillic/utf-8 slug(?)/permalink. topic about another bug with it: http://wordpress.org/support/topic/plugin-wp-super-cache-still-not-corrected-bug-about-unicode-range-letters-in-permalink?replies=10 .

  12. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    Gzip is disabled by default because it broke some sites unfortunately.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic