WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: WP Super Cache] Caching Homepage (6 posts)

  1. apostaganha2
    Member
    Posted 5 years ago #

    My homepage is home.php, i already add this page into de reject urls but it still making the cache :s

    Ideas?

  2. mikejs78
    Member
    Posted 5 years ago #

    Bump

    I am experiencing the exact same problem, except with the default index.php, ever since upgrading to 0.8.7.

  3. dev22
    Member
    Posted 5 years ago #

    simple solution, downgrade back to 0.8.6...

    i am kinda puzzled lately by amount of bugs in this plugin :/

  4. blakekr
    Member
    Posted 5 years ago #

    Same problem! thank you dev, will try your downgrade solution ... duh!

  5. oxclove
    Member
    Posted 5 years ago #

    Found a solution to the Super-cache caching the index or home file!

    I did try the two other solutions I saw – one of which was to create a nocache-home.php file (which did NOT work) – and the other was changing some lines of code in wp-cache-phase2.php (that didn’t work either)

    The problem for me was that super cache was caching my main index file. For me, that was a file called “home.php”. I found that if I accessed that file directly, it was not cached (as I had excluded it in the super cache settings)… BUT, if I just went to my URL, the home.php file was cached. By editing my .HTACCESS file so that users would be forced to go to my home.php file, the file is no longer cached.

    Here is the htaccess directive:
    RedirectMatch permanent ^/$ http://www.myurl.com/home.php

    (replacing ‘myurl’ with your actual URL)

  6. blakekr
    Member
    Posted 5 years ago #

    Hi Oxclove, thanks for testing all those options! In my setup this Redirect visibly directs the user to the home.php page which I do not want to do for SEO reasons, but it's good to know. I guess for now I think I'll just sit on an old version until this little bug gets solved.

Topic Closed

This topic has been closed to new replies.

About this Topic