WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
caching files but no timestamp (5 posts)

  1. jebus
    Member
    Posted 2 years ago #

    I'm having a really weird problem with WP Super Cache. It's generating the cache directories and files. I can see them there, and when I download the actual files (both html and gzip) I can see the time stamp at the bottom.

    But, when the pages are served, there's no timestamp. The built in cache test fails as well. But, oddly enough there are a few blank lines at the bottom of the source of the cached pages, like where the timestamp would be.

    Also, I can generate the cache for two specific category pages, and I can see the time stamp in the source for those. I've tried it a couple times and it's consistent.

    I've also reinstalled WP Super Cache, disabled all other plugins, and tried from a few different browsers with cookies cleared.

    Any chance the cache files are being served, but I'm just not seeing the time stamp at the bottom for some reason? I'm really at a loss, so any help is appreciated.

    Thanks.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. James Revillini
    Member
    Posted 2 years ago #

    Are you using Minify or any plugin that minifies? It could be stripping comments. If so, try disabling it, then delete cache, then reload a page and see if the caching comments are there.

    The cache test failing could be some other issue.

  3. jebus
    Member
    Posted 2 years ago #

    Thanks for responding, jrevillini.

    I'm using Better WordPress Minify, but it does the same thing with that disabled, or with all plugins except WPSC disabled.

    I also viewed the headers, and I don't see any mention of WPSC in that, although it is showing it's gzipped.

    I'm using the Cloudflare CDN, but I don't think that effects the source of the page itself, just images, css, javascript, etc.

  4. jebus
    Member
    Posted 2 years ago #

    It certainly serves the pages like they're cached. If I open the home page in an incognito window in Chrome, they serve right up, much faster than logged in. I'm thinking it's probably working, there's just something stripping the comments out for some reason.

  5. James Revillini
    Member
    Posted 1 year ago #

    I mean, I guess your theme could be doing it too, but it would be pretty weird. IDK, man. Sorry! But at least things are snappy... that's a good thing!

    If you ever figure it out, let us know!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic