WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Cached paged last few minutes?! (11 posts)

  1. petekkia
    Member
    Posted 5 years ago #

    Hi there,
    i've just installed WP Supercache in my website (www.leoclubrc.it), but it looks like pages are cached just for few minutes. If i load the same page 10 times in 4-5 minutes, it's served cached just 4-5 times, as i can read the HTML of the served page (<!-- Cached page served by WP-Cache -->). Nevertheless, thefew times that it's served cached, it's never Super-cached.
    If the number of cached pages, it changes constantly. 21 then 5, then 10...
    I set the expire time to about 10 hours...
    Can someone help me please?
    Thank you very much,
    Fabrizio.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Super Cached pages are not served to logged in users. Only to anon users, who are not logged in.

  3. petekkia
    Member
    Posted 5 years ago #

    I know it, the problem occurs when i'm not logged in.

  4. petekkia
    Member
    Posted 5 years ago #

    Now I'm seeing this:
    1) I delete the whole cache and log out.
    2) I browse the whole site first time, and all pages are served without wp-cache or supercache.
    3) I close the browser window and re-open it. I re-browse the whole site. Most of pages are servers with supercache, others with wp-cache.

    BUT

    if i connect to the site from another computer (my broter's one), of course not logging in, and i browse the site, i must browse the whole site at least one time, to see the cached pages the second time.
    It looks like every pc has to browse the site one time without the caching to "enable" for next visits...
    Is it normal? Shouldn't cached pages be served to everyone at his very first visit?
    Thanks,
    Fabrizio.

  5. petekkia
    Member
    Posted 5 years ago #

    I tried from a third pc. The same problem. First visit for cache, even tough the same page is already served cached to others pc.
    There is any official support forum for this plugin?

  6. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Are you using a plugin that sets cookies on your browser? What is the url of your site?

  7. Roy
    Member
    Posted 5 years ago #

    http://www.leoclubrc.it as stated in the first post :-)

  8. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Oops, missed it there. I get the supercache gz comment on my first visit to your site. Are the PCs you are using going through some sort of proxy or firewall that adds cookies perhaps?

    I visited your newest post and it wasn't supercached, but on reload it was, which is the expected behaviour.

  9. petekkia
    Member
    Posted 5 years ago #

    So, you think it is working properly?
    I asked a friend to go on the website (it was his very first time) The page wasn't server cached :((

  10. petekkia
    Member
    Posted 5 years ago #

    I visited your newest post and it wasn't supercached, but on reload it was, which is the expected behaviour.

    What do you mean? From my pc pages are served cached (wp-cache o supercache), my friend, who for the first time visited the website, had the pages served dynamically.. Not only the homepage, but also all pages. As I said, after the first visit, pages are served dynamically...

  11. Donncha O Caoimh
    Member
    Posted 5 years ago #

    I tried again and the front page is super cached for me, as is your first post. Ask your friend to clear his cookies for your domain.

Topic Closed

This topic has been closed to new replies.

About this Topic