WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Cache Rebuild Not Working - Why do my GZIP files get Rebuilt Every Half Hou (2 posts)

  1. BeyondDomaining
    Member
    Posted 5 years ago #

    I run numerous instances of WordPress for myself and my clients. Most of these sites only receive a moderate amount of traffic.

    I am having a couple of problems with WP Super Cache. I will definitely make a donation if I can get my problems resolved. Love the Plugin otherwise :)

    (1) I have had several people complaining that my sites take too long to load. I don't think WP Super Cache is not doing what it’s supposed to do.

    What's happening (in Firefox) is that every half hour the GZIP-ed compressed cached pages are getting re-built. And that takes an uncomfortable amount of time. So if a visitor comes in 30 minutes after the last GZIP page 'build', they have to wait for the page to get built - i.e. long load time. But if they come in within 30 minutes of the last GZIP build, the GZIP page gets delivered to them quickly and they are very happy - i.e. fast load time.

    Question: isn't the "Cache Rebuild" checkbox feature supposed to fix this? i.e. from the description "Cache rebuild. Serve a supercache file to anonymous users while a new file is being generated. Recommended for very busy websites with lots of comments. Makes "directly cached pages" and "Lockdown mode" obsolete."

    I have the Cache Rebuild box checked, yet, still, every 30 minutes, if I do a "View Source":

    <!-- Dynamic page generated in 2.502 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2009-05-19 09:13:56 -->
    <!-- Compression = gzip -->

    I see that the page delivered was generated at the exact same time as my page request. If the Cache Rebuild is working, shouldn't new visitors be delivered an old page every time? Shouldn't the 'Cached page generated by WP-Super-Cache on….' NEVER equal the exact same time that I make a page request? And, beyond the first GZIP "build", shouldn't no one every actually have to 'wait' for a page to be built?

    (2) I know that the "Expiry Time and Garbage Collection" setting has a maximum of 1800 seconds, so I figured, OK that's cool - this Plugin was developed for high traffic sites than need to clear the cache maybe I can go into the Plugin Editor and edit wp-super-cache/wp-cache.php so that $cache_max_time = 90000 (i.e. adjust the cache max time so that I can expire the cache approximately once per day, instead of once every 30 minutes (which is the current maximum)).

    I'm not a programmer by any means, so I probably did this wrong, but I made the change in a few places:

    line 747: $cache_max_time = 90000;

    line 1242: $next_gc = $cache_max_time < 90000 ? $cache_max_time : 90000;

    This seems to have worked in Firefox 3.0.1. However, I'm sure I missed something…. are there any other 'tweaks' I need to do to make sure I have done this completely correctly? i.e. Given that the “Cache Rebuild” feature described in #1 above is NOT working, is there anything else I need to do to ensure that my 90000 second $cache_max_time ‘workaround’ is being done correctly?

    But it DOES NOT seem to have worked in Internet Explorer 7.0...

    (3) Regardless of the above change, every time I load a page in IE7, WP Super Cache (i) DOES NOT build a GZIP file (see below) and it (ii) still rebuilds / generates a new cached page EVERY single time a page is loaded. i.e. it NEVER delivers a previously cached page – it ALWAYS delivers an newly generated page.

    <!-- Dynamic page generated in 2.939 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2009-05-19 09:27:36 -->

    4) everything else seems to be working fine. (I’m using Godaddy Deluxe Shared Linux hosting, if that matters)

  2. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Will you try the development version off the download page? That may help.

Topic Closed

This topic has been closed to new replies.

About this Topic