WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Blank Pages - 500 Errror - in Dashboard (sometimes the site too) (15 posts)

  1. think2wice
    Member
    Posted 5 years ago #

    With WP Super Cache Enabled, every few hours I get the php 500 error (or w/e it's called) throughout my entire wordpress installation - the site, the admin, everything. And the only way to bring it back is to reboot Apache.

    Someone had a problem similar to this, and got it resolved for themselves. Well for me, the issue isn't resolved. I still get 500 errors several times throughout the day when I'm using the wp super cache plugin. I'm on WordPress 2.6, and I got the same problems with 2.5 and 2.5.1. The plugins I have running are:

    Akismet
    Audio Player
    Different Posts per Page
    Feedburner Feed Replacement (dashboard only plugin)
    Force Word Wrapping
    Kimili Flash Embed
    No Howdy (wp-admin only plugin)
    No Self Pings
    Optimal Title
    Page Post
    Post Avatar
    Role Manager
    SEO Post Link
    Simple Tags
    Theme Test Drive
    Wordpress Video Plugin
    WP-PageNavi
    WP-Polls
    WP-PostViews
    WP-RelativeDate

    The site works fine, other than it loading slowly, when I disable the plugin. Someone mentioned mod rewrite rules or something like that. Can this be fixed? I would really love to utilize this great program! But I can't have my site going down every few hours. I'd rather it just load a little slower...

  2. think2wice
    Member
    Posted 5 years ago #

    Bump ... anyone?

  3. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Have you checked your php error_log? Have you tried disabling some of those plugins? Perhaps your server doesn't have the capacity to run all of them plus the caching plugin. Unfortunately gzipping content like the caching plugin does takes up a lot of memory.

  4. think2wice
    Member
    Posted 5 years ago #

    Yeah, I think another plugin might be causing the issue, in addition to wp cache. I still get 500 errors with it disabled (but not as much - maybe once a day, or every couple of days). The only difference is that when wp cache causes 500 errors, the entire site is down. When I have it off, and I still get 500 errors, only the top portion of the dashboard shows up.

    Donncha, what should I look for in my php error_log? This can be found in /etc/httpd/logs right?

  5. henkmsncam
    Member
    Posted 5 years ago #

    I got the same problems but also with all plugins (ecxept askimet) disabled!

  6. think2wice
    Member
    Posted 5 years ago #

    So maybe akismet is the problem lol. The one plugin no one disables or is afraid to disable.

  7. Donncha O Caoimh
    Member
    Posted 5 years ago #

    I don't know what to look for, except if there are errors in there it might be better to fix them, because they might be causing this problem.

    You could also define WP_MEMORY_LIMIT to a large memory size, maybe even "64M" like this. Add this line to wp-config.php before the last require_once()

    define('WP_MEMORY_LIMIT', '64M');

  8. think2wice
    Member
    Posted 5 years ago #

    And what would that do?

  9. Rok
    Member
    Posted 5 years ago #

    define('WP_MEMORY_LIMIT', '64M');

    This command will increase PHP memory to 64M.

  10. doncot
    Member
    Posted 5 years ago #

    I got the same '500 Internal Server Error'

    /var/www/blog/wp-content/cache/.htaccess: ExpiresActive not allowed here

    After I delete cache,then I can view the site once.

  11. doncot
    Member
    Posted 5 years ago #

    My website for example is : http: //blog.mywebsite.com/

    refer to Troubleshooting:
    10.If pages are randomly super cached and sometimes not, your blog can probably be viewed with and without the "www" prefix on the URL. You should choose one way and install the Enforce www preference( http://txfx.net/code/wordpress/enforce-www-preference/)plugin.

    But it still can't work.Could someone help me.thx

  12. Donncha O Caoimh
    Member
    Posted 5 years ago #

    doncot - edit that .htaccess and remove the "ExpiresActive" line, or fix your Apache config so it's supported. (It's late here, can't check, but look in the .htaccess and you'll see the module)

    Add a rewrite rule to your .htaccess to enforce whichever www preference you prefer.

  13. doncot
    Member
    Posted 5 years ago #

    Thanks donncha,

    I edited wp-content/cache/.htaccess and removed following lines:
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType text/html A300
    </IfModule>

    or fix my Apache config file like below:
    <Directory "/var/www/blog">
    Options FollowSymLinks
    AllowOverride FileInfo AuthConfig --> AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    Now It is ok.
    But I have not got idea how to rewrite my .htaccess.(do you mean /.htaccess or wp-content/cache/.htaccess ?)
    And how to fix my Apache config file?

    Anyway,Thank you so much. :)

  14. Donncha O Caoimh
    Member
    Posted 5 years ago #

    "But I have not got idea how to rewrite..."

    What do you mean? You just did rewrite the .htaccess and fixed the Apache config ..

  15. pigneckring
    Member
    Posted 5 years ago #

    What is the Apache config fix, specifically? In other words, what lines would I add to or edit in Apache config? Or is it RTFM? If so, which M? What topic in the M?

    I installed wp-super-cache last night and woke up to find a dead site (the admin worked though), with this in the logs:

    [Sat Oct 18 01:45:35 2008] [alert] [client 55.55.55.55] /usr/local/www/data/pathtomysite/wp/wp-content/cache/.htaccess: ExpiresActive not allowed here

Topic Closed

This topic has been closed to new replies.

About this Topic