WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
adding images to a post (14 posts)

  1. Salomon Amiga
    Member
    Posted 1 year ago #

    Hi

    After your latest update, my editors, when they want to upload an image to a post they get a message "are you sure you want to do this ???"

    so i had to deactivate the plugin

    please fix it, in order to activate it again

    tnx in advance

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. chrisanthropic
    Member
    Posted 1 year ago #

    I just wanted to chime in that I'm having the same problem here. Admins are able to upload media and insert to a post but nobody else can insert media.

    This happens with new users and old, on new posts and old.

  3. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    I can't replicate that on my own site unfortunately. That warning is usually when a nonce has expired or is wrong in some way.

    Can you turn on debugging in the plugin before you edit a post and then try uploading? The attempt to upload should be logged and the log should say it's not cached.

  4. chrisanthropic
    Member
    Posted 1 year ago #

    Thanks for the quick reply, here's what I'm pretty sure is the relevant part of the log:

    16:22:05 /wp-admin/admin-ajax.php In WP Cache Phase 2
    16:22:05 /wp-admin/admin-ajax.php Setting up WordPress actions
    16:22:05 /wp-admin/admin-ajax.php Not caching wp-admin requests
  5. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    I suspect some other plugin is interfering. Did you update a number of plugins when you updated WP Super Cache?

  6. chrisanthropic
    Member
    Posted 1 year ago #

    Yep, kept digging around and it seems like the newest update of the Jetpack plugin is the culprit. Everything's fine when I disable it.

    Thanks for the help, now I need to either bug them about it or see which plugin the customer would rather do without.

  7. Salomon Amiga
    Member
    Posted 1 year ago #

    HI, chrisanthropic, how do you know JetPack is making this ???

    i disable it as well but still got the problem

  8. chrisanthropic
    Member
    Posted 1 year ago #

    There may be other plugins that cause the same issue in your case. For me, I disabled jetpack and re-enabled WP Super Cache and the problem disappeared. As soon as I re-enabled jetpack the problem returned.

  9. Salomon Amiga
    Member
    Posted 1 year ago #

    well i hope the members of WP cache can help me with an update ;(

    anyway tnx a lot for your time

  10. chrisanthropic
    Member
    Posted 1 year ago #

    No problem - good luck!

    If you think it may be another plugin and you're not sure what you've recently updated (I wasn't, honestly) try logging in to your server, open a file manager and arrange the plugins folder by date last modified. That will tell you the order they've been updated. From there you can try disabling them one by one until you find the culprit.

  11. Salomon Amiga
    Member
    Posted 1 year ago #

    sounds good but i dont know how to "log in to the server and open a file manager and arrange the plugins folder by date last modified"

    maybe you can tell me how to do that ?

  12. chrisanthropic
    Member
    Posted 1 year ago #

    whoever your webhost is (bluehost, godaddy, hostgator, etc) should have a login page, ideally with Cpanel.

    Does any of that ring a bell? If not, there's not a lot I can do from here.

  13. Salomon Amiga
    Member
    Posted 1 year ago #

    oh rigth, i got you know .. il try to do that and see what happens

    tnx !!!

  14. chrisanthropic
    Member
    Posted 1 year ago #

    Cool, good luck!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.