WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] 403 Forbidden (9 posts)

  1. xof711
    Member
    Posted 5 years ago #

    I'm getting a 403 Forbidden to access index.html in the supercache folder.

    It seems that since the 0.8 update today, the index.html created doesn't have the right permission. Permission is set at 600 and I think it should be 755.

  2. whooami
    Member
    Posted 5 years ago #

    I think it should be 755.

    No .html or .php file needs to be chmod 755, so you are wrong.

    Try 644 or something else that begins with 6.

    and if youre getting a permission error, just use your ftp client, and chmod the file. its not that hard.

  3. xof711
    Member
    Posted 5 years ago #

    I tried that, then it works but when supercache cleans the expired pages, it resets to 600, then I get the 403 error again.

    Right now I turned it to Half-off but it's not a solution.

  4. Donncha O Caoimh
    Member
    Posted 5 years ago #

    xof711 - are you using something like suphp? Does php run as a different user to Apache? I'm going to add a fix for this that changes the perms but it should work, because 600 means it's readable by the owner. Which is why I think the script and Apache are running as different users ..

  5. musiclover-bg
    Member
    Posted 5 years ago #

    Just to let know that xof711 is not the only one.. I'm using the biggest hosting service provider in Bulgaria, and I've also gotten the same error. I had to restore a backup with the earlier version.

  6. Amit Agarwal
    Member
    Posted 5 years ago #

    I too have the same issues when using super cache with labnol.org

    The apache error log has tons of entries like this after I upgraded to v .8

    Permission denied: file permissions deny server access:

    Will re-enable the plugin once a fix is out.

    Thanks.

  7. ulyssesr
    Member
    Posted 5 years ago #

    I woke up this morning and saw my home page had a forbidden file access error in the cache directory. I think the problem surfaced after the Super Cache upgrade yesterday. I deleted the cache directory and removed the plugin. I'll wait for a fix. Thank you.

  8. tigertech
    Member
    Posted 5 years ago #

    This is probably due to the issue I posted in the last post of http://wordpress.org/support/topic/201085?replies=7.

    The one-line change there will fix it.

  9. xof711
    Member
    Posted 5 years ago #

    tigertech, this describes it perfectly. Thanks...

    There is a new update tho, 0.8.1 and hopefully, this will fix the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic