WordPress.org

Ready to get started?Download WordPress

Forums

WP Stripe
[resolved] Page not found (10 posts)

  1. HydraRobots
    Member
    Posted 2 years ago #

    I have placed [wp-stripe] in my content on one of my pages and the button seems to be up and running fine, however, whenever it is clicked a window pops up but its content is

    "Page not found
    The page you are looking for might have been removed,
    had its name changed, or is temporarily unavailable. "

    I had installed version Version: 1.3.3 of the WP-Stripe plugin through WordPress.

    Any help? (Also worth noting, I have no right to be doing any of this. I'm a mechanical engineer getting a site limping along for a robotics startup and we're working with a government purchaser who want to use a credit card. So keep that in mind when responding)

    http://wordpress.org/extend/plugins/wp-stripe/

  2. Noel Tock
    Human Made
    Plugin Author

    Posted 2 years ago #

    Do you have a live example somewhere?

    Cheers!

    Noel

  3. HydraRobots
    Member
    Posted 2 years ago #

    Hey Noel,

    Thanks for the quick response.

    http://www.hydraintelligentsystems.com/online-payment-portal/

  4. Noel Tock
    Human Made
    Plugin Author

    Posted 2 years ago #

    Hmmm, the file should exist, do you see it in your directory, is that folder restricted somehow?

    http://www.hydraintelligentsystems.com/wp-content/plugins/wp-stripe/includes/stripe-iframe.php

  5. HydraRobots
    Member
    Posted 2 years ago #

    Hey Noel,

    That file does indeed exist.

    Here is its content

    <?php

    // Include WordPress Header

    define('WP_USE_THEMES', false);
    require('../../../../wp-blog-header.php');

    // Head

    ?>

    <!doctype html>
    <html lang="en">
    <head>

    <meta charset="utf-8">
    <title><?php _e('Stripe Payment','wp-stripe'); ?></title>
    <link rel="stylesheet" href="<?php echo WP_STRIPE_PATH . '/css/wp-stripe-display.css'; ?>">
    <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js"></script>
    <script src="https://js.stripe.com/v1/"></script>

    </head>
    <body>

    <?php

    // Stripe

    echo wp_stripe_form();

    // Footer
    ?>

    </body>
    </html>

    <?php

    ?>

  6. Noel Tock
    Human Made
    Plugin Author

    Posted 2 years ago #

    Weird, so it's likely to be a permissions issue on that sub-directory. Is it set to 644 or is it an IIS server?

  7. HydraRobots
    Member
    Posted 2 years ago #

    Hey Noel,

    The directory containing the WP Stripe plugin is set to 777.

  8. Noel Tock
    Human Made
    Plugin Author

    Posted 2 years ago #

    Is it IIS/ASP? Cheers!

  9. HydraRobots
    Member
    Posted 2 years ago #

    Hey Noel,

    It is Debian, not IIS.

  10. Noel Tock
    Human Made
    Plugin Author

    Posted 2 years ago #

    Wondering if Debian does anything, or if the htaccess does. The file is obviously there, if my code was somehow "messed up", it would error out instead of 404 (permissions, location, redirects, etc.). Maybe ask the host?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.