WordPress.org

Ready to get started?Download WordPress

Forums

WP Stripe
[resolved] Not working on interior pages (7 posts)

  1. seancote
    Member
    Posted 2 years ago #

    The shortcode is currently working on a post that shows up on the home page, but when I use the shortcode on a page or post otherwise, the page goes dark but the payment form doesn't pop up. Any suggestions as to why this might be the case?

    ex: http://www.keyofhope.org/test-page/

    http://wordpress.org/extend/plugins/wp-stripe/

  2. Noel Tock
    Human Made
    Plugin Author

    Posted 2 years ago #

    Weird, you may need to use the legacy shortcode then. Seems like there's interference from another plug-in (assuming that you also have my CSS activated).

  3. Noel Tock
    Human Made
    Plugin Author

    Posted 2 years ago #

    Sean, you have this fixed yet? Cheers

  4. seancote
    Member
    Posted 2 years ago #

    I do have your CSS activated. I tried turning off a couple plugins to no avail. We have only the plugins we need, so I'll use the legacy shortcode and be happy with this great thing you've provided us!

  5. seancote
    Member
    Posted 2 years ago #

    After trying a few other things I finally tried disabling all other plugins except wp-stripe and it still didn't help. So it doesn't seem to be a plugin conflict.

    I get this error when I inspect the element:
    http://www.(domain).org/wp-content/plugins/wp-stripe/includes/stripe-iframe.php?keepThis=true&
    Failed to load resource: the server responded with a status of 404 (Not Found)

    Any other suggestions?

  6. seancote
    Member
    Posted 2 years ago #

    I just noticed that on the pages it doesn't display the style
    visibility:hidden loads on the #TB_window from wp-stripe-thickbox.css. If I uncheck that style while inspecting the element it'll show up. Not sure if that helps.

  7. seancote
    Member
    Posted 2 years ago #

    Turns out it was just an old version of wordpress. It was higher than 3.1, but once updated to 3.3.1 it works just fine.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags