WordPress.org

Ready to get started?Download WordPress

Forums

WP Stripe
[resolved] Invalid API Key provided (14 posts)

  1. AndyStreet
    Member
    Posted 2 years ago #

    I get this error message every time I try to process a payment.

    Oops, something went wrong (Invalid API Key provided: xxxxxxxxxxxxxxxxxxxxxxxxxxxxx)

    This is using the plugin, with a shortcode displaying the payment form in a blog post. I copied & pasted the key, it's good.

    What's wrong?

    http://wordpress.org/extend/plugins/wp-stripe/

  2. Noel Tock
    Human Made
    Plugin Author

    Posted 2 years ago #

    Hi Andy, there's two API keys, make sure you're using the correct one in the test area as well as production then.

  3. AndyStreet
    Member
    Posted 2 years ago #

    There are two API keys for test and two for production. All 4 keys are correctly entered in the plugin's settings. I always get the above error, no matter if it's the test card or a real one. On stripe.com everything is working fine but on my website nothing works.

  4. Noel Tock
    Human Made
    Plugin Author

    Posted 2 years ago #

    Interesting, thanks for the feedback. I've had both test & real transactions work, so not sure what's going on with your particular install. What are the details of the environment you're testing on? Cheers

  5. AndyStreet
    Member
    Posted 2 years ago #

    Noel - it's a Multisite install, v3.2.1. I'm testing with a shortcode on a page on the primary blog. I will send you details if you would be kind enough to help me troubleshoot.
    Thanks.

  6. Noel Tock
    Human Made
    Plugin Author

    Posted 2 years ago #

    Ah, let me have a look at that then from my side first to see if it's related to that.

    Cheers

    Noel

  7. AndyStreet
    Member
    Posted 2 years ago #

    Cool. I emailed you a link to the page.

    Andy

  8. AndyStreet
    Member
    Posted 2 years ago #

    Any news...?

  9. Noel Tock
    Human Made
    Plugin Author

    Posted 2 years ago #

    Hi Andy,

    No sorry, I haven't been able to isolate the issue or figure out why it would reject the key yet (i.e. haven't been able to reproduce). It would likely be quite helpful to see other users that experiencing similar issues (which we haven't yet for this).

    Cheers

    Noel

  10. jpleas
    Member
    Posted 2 years ago #

    We're experiencing the same issue as described above. Not sure why.
    Running WP 3.4.1 and API keys are set up correctly.
    Can I provide any additional info to help?

  11. jpleas
    Member
    Posted 2 years ago #

    Wait - never mind - reread and we had a different error msg.
    And I figured it out from our error msg.
    Sorry about the false alarm...

  12. Noel Tock
    Human Made
    Plugin Author

    Posted 2 years ago #

    Cool :)

  13. kappu
    Member
    Posted 2 years ago #

    how to get API key for this plugin?

  14. Noel Tock
    Human Made
    Plugin Author

    Posted 2 years ago #

    stripe.com developer

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags