WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: wp-stattraq] missing ABSPATH definition (7 posts)

  1. netzgeschaedigt
    Member
    Posted 5 years ago #

    Attention: in order to get this plug-in to work in 2.7+, you have to make a small adjustments in 'stattraq-install.php'.

    You can fix the problem of the missing ABSPATH declaration (actually it's defined in wp-config.php ^_~) by replacing 'ABSPATH.' with a normal variable containing the path to your blog installation.

    $path = 'http://your.wordpress.url';
    require_once($path.'/wp-config.php');

    Please remember, if your blog is placed in a sub-folder you have to consider this in the '$path' variable, e.g.:

    $path = 'http://your.domain.url/wpfolder';

    This is only one possible solution - maybe not the nicest one but a fast, quick and dirty trick to make the installation work ^-^

    http://wordpress.org/extend/plugins/wp-stattraq/

  2. strings28
    Member
    Posted 5 years ago #

    I'm going to be changing the way this works in 1.3.1 so that when you first log into the StatTraq interface it uses the Options view to give you what you need as far as installation and upgrading goes. It'll also do it behind the scenes so everything feels more fluid.

    I know, its late, but its better than never :)

  3. Gersprenz
    Member
    Posted 5 years ago #

    In some cases the file "wp-config.php" is not in the WordPress root directory (for security reasons). Then the installation failed.

    And in some cases it's impossible to call the initial setup-script ('stattraq-install.php' ) in the plugin directory directly via the browser (also for security reasons).

  4. pwkingston
    Member
    Posted 4 years ago #

    I am trying to get this plugin to work with Version 2.8.6

    I cant tell exactly where I need to edit the file....

    I need to edit stattraq-install.php, and replace line 19 from

    require_once(ABSPATH.'/wp-config.php');

    to

    require_once(http://www.mydomain.com/wordpress'/wp-config.php');

    ?

    I can't get that to work, so that must not be it, but I can't find any other ABSPATH references in the stattraq-install.php file.

  5. pwkingston
    Member
    Posted 4 years ago #

    I also tried adding these 2 lines in place of line 19

    $path = 'http://www.mydomain.com/wordpress';
    require_once($path.'/wp-config.php');
  6. pwkingston
    Member
    Posted 4 years ago #

    Should I edit wp-config.php?

    Where exactly?

  7. pwkingston
    Member
    Posted 4 years ago #

    *deleted* duplicate

Topic Closed

This topic has been closed to new replies.

About this Topic