WordPress.org

Ready to get started?Download WordPress

Forums

WP-Stats-Dashboard
[resolved] Crashed my admin (6 posts)

  1. phodgeszoho
    Member
    Posted 3 years ago #

    Installed and activated the plug-in via the admin. After activation no page in the admin will display.

    Viewed the source code of the generated page and it stops abruptly

    <!-- wp-stats-dashboard by Dave Ligthart http://daveligthart.com -->
    <script type="text/javascript" language="javascript">
    /* <![CDATA[ */

    ...

    </script>
    <!-- /wp-stats-dashboard by Dave Ligthart -->

    Nothing displays in any admin page after this closing comment.

    Had to FTP into the account and delete the plug-in.

  2. daveligthart
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks, I'll remove it in the next version.

    Which web browser / version do you use?

  3. phodgeszoho
    Member
    Posted 3 years ago #

    I was using Firefox 3.6.12 on a MAC when I uploaded and activated the plug-in but after the admin went blank I tried viewing it in Safari and also I.E. on the PC (via VMWare) but no luck in either. The pages were not rendering because no HTML was being generated after the closing comment:

    <!-- /wp-stats-dashboard by Dave Ligthart -->

    Let me know if you have any suggestions fixes etc as I am happy to try it again.

  4. daveligthart
    Member
    Plugin Author

    Posted 3 years ago #

    Perhaps your hosting provider doesn't allow connections to be made to the outside world. You might want to check this with them. Let me know how it turns out.

  5. daveligthart
    Member
    Plugin Author

    Posted 3 years ago #

    Perhaps you could try the new version 3.4.7 ? It has the option to disable the widgets on the main admin dashboard. I've created a separate page "Dashboard Stats" where the stats widgets are also displayed.

  6. txyoji
    Member
    Posted 3 years ago #

    I had the same problem.
    After login, I couldn't load my dashboard anymore.
    I didn't have curl installed. After I installed it then everything loaded as expected.

    This was in my log:
    PHP Fatal error: Call to undefined function curl_init() in /var/www/wp-content/plugins/wp-stats-dashboard/classes/util/metrics/WPSDStats.php on line 195

    I'd add a function_exists('curl_init') check in your register_activation_hook().

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic