WordPress.org

Ready to get started?Download WordPress

Forums

WP socialshareprivacy
[resolved] Plugin installiert und es funktioniert nix (14 posts)

  1. OtaQ
    Member
    Posted 2 years ago #

    Ohne Anleitung ist es relativ sinnlos SO ein Plugin anzubieten.
    Ich habe es installiert, FB API eingegeben und schwupps - nix passiert. Solche Plugins stehlen Zeit, sonst nix. Schade.

    http://wordpress.org/extend/plugins/wp-socialshareprivacy/

  2. boxi
    Member
    Plugin Author

    Posted 2 years ago #

    Hallo, ich habe es auf mehreren Seiten getestet und konnte keine Probleme feststellen. Um das Problem nachvollziehen und reparieren zu können, würde ich mir gerne den HTML-Code deiner Seite anschauen. Kannst du mir die URL geben?

    VG

  3. Utanklaus
    Member
    Posted 2 years ago #

    hallo boxi,
    zum leidwesen der internationale nochmal auf deutsch ...
    - bin (bzw. wäre) begeistert! (wenn das plugin funktionieren würde).

    hier die fehlermeldung:

    Das Plugin kann nicht aktiviert werden, da es einen fatalen Fehler erzeugt. Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /mnt/webd/a2/43/5845343/htdocs/WordPress_04/wp-content/plugins/wp-socialshareprivacy/includes/wpssp_admin.php on line 30

    mein browser: firefox 6.0.2 | und die aktuelle wordpress-version
    php-version weiß ich grad nicht, kenn mich da blöderweise nich so aus.

    woran könnte es liegen ?? wäre dir sehr dankbar verbunden, wenn du mir helfen könntest.

    beste grüsse !

  4. Utanklaus
    Member
    Posted 2 years ago #

    liegt das problem vielleicht an anderen social-wp-plugins wie z.b- sexy bookmarks, das ich jedoch vor der aktivierung des +2 deaktiviert hatte ? kann eigentlich nicht sein ...

    achja, und was meinst du mit 'Zum jetzigen Zeitpunkt können die Buttons nur genau einmal gleichzeitig auf der Seite eingebaut werden' ?

  5. boxi
    Member
    Plugin Author

    Posted 2 years ago #

    Hallo Utanklaus,

    das Problem hängt mit einer alten PHP-Version bei dir zusammen und ist in der Plugin-Version 0.5.1, welche in Kürze zur Verfügung steht, behoben.

    "Zum jetziger Zeitpunkt genau einmal gleichzeitig": Damit meine ich, dass die Social-Buttons momentan noch nicht z.B. auf der Startseite deines Blogs eingebaut werden können, sondern nur in der Artikelansicht. Dieser Umstand wird sich aber vermutlich in wenigen Tagen ändern.

    VG

  6. maggy-X84
    Member
    Posted 2 years ago #

    hallo.

    ich habe das plugin auch installiert und sehe leider im frontend nichts. nur ein leeres div namens socialshareprivacy.
    weiss jemand, was da los ist?

    VG

  7. boxi
    Member
    Plugin Author

    Posted 2 years ago #

    Hallo maggy-X84,

    hast du im Backend die gewünschten Dienste aktiviert? Links findest du unter "Einstellungen" --> "WP socialshareprivacy".

  8. maggy-X84
    Member
    Posted 2 years ago #

    Ja. Es steht alles auf "on" und ist ausgefüllt.

  9. maggy-X84
    Member
    Posted 2 years ago #

    Gibt es vielleicht einen Link zu einem WP Blog, wo das Plugin läuft und sichtbar ist?

    Ich glaub der Javascript Code, der ausgegeben wird, schaut komisch aus ...

    (function($){
    var options = {"info_link":"http:\/\/www.heise.de\/ct\/artikel\/2-Klicks-fuer-mehr-Datenschutz-1333879.html","txt_help":"Wenn Sie diese Felder durch einen Klick aktivieren, werden Informationen an Facebook, Twitter oder Google in die USA ...

    Die Links und Slashes ...

  10. boxi
    Member
    Plugin Author

    Posted 2 years ago #

    Ich persönlich betreibe keinen öffentlichen Blog.

    Der Javascript-Code sieht korrekt aus. Wenn du mir einen Link auf deinen Blog gibst, kann ich (später) mal schauen ...

  11. maggy-X84
    Member
    Posted 2 years ago #

    Link ist schwierig. Das ganze geht noch im Develop-Modus und ist noch nicht veröffentlicht ...
    Aber danke für das Angebot! ;)

  12. boxi
    Member
    Plugin Author

    Posted 2 years ago #

    Gibt denn die Javascript-Fehlerkonsole etwas aus? Hast du irgendwelche Firefox-Plugins installiert, die Kommunikation unterdrücken? (noscript, noads etc)

  13. maggy-X84
    Member
    Posted 2 years ago #

    Ne die Console wirft keine Fehler.
    Ich sehe das leere div in jedem Browser - Chrome, FF, IE

  14. boxi
    Member
    Plugin Author

    Posted 2 years ago #

    Dann ist es vielleicht nur ein Anzeigeproblem - magst du mal testweise ein anderes Theme ausprobieren?

    Das leere div wird übrigens per JavaScript durch etwas anderes ersetzt, sobald die Seite geladen ist. Wenn es Javascript-Probleme gäbe, würden diese wahrscheinlich in der Fehlerkonsole auftauchen.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic