WordPress.org

Ready to get started?Download WordPress

Forums

WP Smush.it
Strange Error (49 posts)

  1. thinkfuture
    Member
    Posted 2 years ago #

    My Smush.it seems to have stopped wokring not sure why:

    Smush.it error: Could not get the image while processing http://freedombunker.com/wp-content/uploads/2012/01/20120123_055131_do23-president-obama-state-of-the-union_400.jpg
    (C:Inetpubthinkfuture.comhtmlcfs/wp-content/uploads/2012/01/20120123_055131_do23-president-obama-state-of-the-union_400.jpg)

    For some reason it seems to be deleting all backslashes above the WP directory when looking for the file. Any ideas???

    http://wordpress.org/extend/plugins/wp-smushit/

  2. gigafytes
    Member
    Posted 2 years ago #

    I'm getting the same error message:

    Smush.it error: Could not get the image while processing http://gigafytes.com/wp-content/uploads/2012/01/wpid-Photo-Jan-24-2012-1154-AM.jpg (/nfs/c09/h04/mnt/139662/domains/gigafytes.com/html/wp-content/uploads/2012/01/wpid-Photo-Jan-24-2012-1154-AM.jpg)

  3. Tosh
    Member
    Posted 2 years ago #

    +1 same error message here. Disabling the plugin for now. Hope it's a temp thing.

  4. lindaloustarr
    Member
    Posted 2 years ago #

    I'm having the same issue, same message, since a few days ago . . .
    Linda Lou

  5. RadialBlur
    Member
    Posted 2 years ago #

    same error i figured out we are all using CLOUDFLARE.COM i chacked your dns same

  6. whitehallsd
    Member
    Posted 2 years ago #

    I'm getting the same error. Smush.it error: Could not get the image while processing http://whitehallsd.k12.wi.us/wp-content/uploads2012/01/sunset2.jpg (/home4/whitehb8/public_html/whitehallsdk12wi/wp-content/uploads/2012/01/sunset2.jpg)

    I noticed that the slash is missing between uploads and 2012. Why would that be?

  7. damoncloudflare
    Member
    Posted 2 years ago #

    Hi,

    We have an engineer that is testing this out. I did want to highlight that it is very easy for you to see if CloudFlare is actually causing this.

    1. Temporarily deactivate CloudFlare in your CloudFlare settings (settings->deactivate/pause CloudFlare).
    2. Wait about ten minutes.
    3. Try to run the plugin again.

    Note: Do all of the users have a beta feature called Rocket Loader turned on? I did notice that one of our inbound contacts did have Rocket Loader turned on, which can impact some scripts, so I'm curious if turning that feature off fixes the issue.

  8. damoncloudflare
    Member
    Posted 2 years ago #

    Just a quick note that I tested Smush.it on my personal blog without any issues.

    A couple of quick questions:
    1. Are you having the issue when doing one smush or a bulk smush?
    2. Are you using any other caching plugins?
    3. Which version of WordPress are you using?

  9. RadialBlur
    Member
    Posted 2 years ago #

    This is about cloudflare dns settings. my dns settings

    A mydomainname.com points to ip.... with automatic TTL is on
    and
    CNAME www. is on

    (others off) smush.it is working know.

    wordpress 3.3.1

    optimize plugins.
    CSS-JS-Booster
    Head Cleaner
    Improve My Load Times
    W3 Total Cache
    WP Minify
    WP Smush.it
    WP Super Cache (using for small fonc.)
    and .htaccess settings

  10. whitehallsd
    Member
    Posted 2 years ago #

    damoncloudflare:

    1. Having issues for both smush.it and bulk smush.it

    2. W3TC

    3. WordPress 3.3.1

    I have also recently moved our site to a new host which could be giving me problems. I have temporally disabled cloudflare and will post back here a bit later.

  11. whitehallsd
    Member
    Posted 2 years ago #

    Disabled cloudflare and still getting issue. It's still leaving out a slash in the image url between uploads and 2012

    http://whitehallsd.k12.wi.us/wp-content/uploads2012/02/sunset-new.jpg.

  12. damoncloudflare
    Member
    Posted 2 years ago #

    Hi,

    Ok, can you try to turn W3TC off as a test? It is the only common thread I see so far besides CloudFlare. If CloudFlare is off when this happens, then this error isn't coming from us.

    Just a quick note on this one:
    W3 Total Cache
    WP Minify
    WP Smush.it
    WP Super Cache (using for small fonc.)

    Generally speaking, you really only want to use one plugin for caching. As they all work differently, they can cause conflicts with one another.

  13. RadialBlur
    Member
    Posted 2 years ago #

    Damoncloudflare, my web site working properly now with smush.it and cloudflare, thank you for interest. whitehallsd should try.

    A mydomainname.com points to ip.... with automatic TTL is on
    and
    CNAME www. is on

    optimize plugins.
    CSS-JS-Booster
    Head Cleaner
    Improve My Load Times
    W3 Total Cache
    WP Minify
    WP Smush.it
    WP Super Cache (using for small fonc.)
    and .htaccess settings

  14. whitehallsd
    Member
    Posted 2 years ago #

    Unfortunately is is not working for me. Tried without cloudfare and disabled w3tc and I'm still getting that error with the slash missing. Thanks for all the help. Will post if I figure it out.

  15. whitehallsd
    Member
    Posted 2 years ago #

    Ok, here is what I have done.

    I changed the path to my upload folder (I had the full path the folder which is not what I needed on the new host) and then disabled cloudflare and now smush.it is working now. I cleared both my w3tc cache and my cloudflare cache, reenabled cloudflare and am getting that error again. My upload path is wp-content/uploads and now when I enable cloudflare I am getting /home4/whitehb8/public_html/whitehallsdk12wi/wp-content/uploads.

    Cloudfare is bringing back those old settings even though I cleared the cache. Any suggestions?

  16. lindaloustarr
    Member
    Posted 2 years ago #

    I am still getting this error:

    Smush.it error: Could not get the image while processing http://lindaloustarr.com/review/wp-content/uploads/featured.png (/home/content/88/8433488/html/review/wp-content/uploads/featured.png)
    Re-smush

    cloudflare settings:
    Basic Security Level = Medium
    Caching Level = Basic
    Automatic IPv6 = off
    Minimum Expire TTL = 4 hours
    Auto Minify = CSS & HTML (JS creates error)
    Rocket Loader = off
    Challenge Passage TTL = 45 minutes
    Customize Challenge Page = not customized
    Advanced Security = off
    Website Preloader = off
    Outbound Links = on
    E-mail Address Obfuscation = on
    Server Side Exclude = on
    Always Online = on
    IP Geolocation = on
    Google Analytivs = managed/on
    SSL Pro = off
    Browser Integrity Check = off
    Hotlink Protection = off
    Development mode = off

    I did deactivate no change
    Plugins are:
    Akismet
    Cloudflare
    Widget Logic
    WP-Orphanage
    WP-Page Navi
    WP-Smush.it

    Had no problems with Smush.it before Cloudflare . . .
    Linda Lou

  17. RadialBlur
    Member
    Posted 2 years ago #

    Linda you should try change cloudflare dns settings.

    A yourdomainname.com points to ip.... with automatic TTL is on
    CNAME www. is on

    other dns settings try off

  18. damoncloudflare
    Member
    Posted 2 years ago #

    Hmmm...still find it out that some say it happens without and with CloudFlare. Let's try this...

    We have a beta feature called Page Rules that you can access here: https://www.cloudflare.com/preview-page-rules. After activating the beta, go to the Page Rules that you will in the CloudFlare settings drop down choices.

    You should then drop in your URL for the upload, such as:

    gigafytes.com/wp-content* (be sure to include the wildcard)

    The turn off all of the security and performance options (change cache to bypass cache, etc.).

    Note: I would also recommend excluding your admin url us, such as gigafytes.com/wp-admin*

  19. whitehallsd
    Member
    Posted 2 years ago #

    I tried your example above and then turned on cloudflare. Now getting the error again.

    Smush.it error: Could not get the image while processing http://whitehallsd.k12.wi.us/wp-content/uploads/2012/02/Classroom-Photos-2005-019.jpg (/home4/whitehb8/public_html/whitehallsdk12wi/wp-content/uploads/2012/02/Classroom-Photos-2005-019.jpg)

  20. whitehallsd
    Member
    Posted 2 years ago #

    Ok, I changed the pattern from wp-content* to wp-content/* It now seems to be working and I am going through cloudflare.

    My only concern now is that the wp-content folder contains many files that should be cached, and now they will not be with this exception correct?

  21. lindaloustarr
    Member
    Posted 2 years ago #

    I tried the page rules this morning wp-content/uploads - smush.it is now working - however, by setting all the page rule settings to off & no caching won't that make my site load slower since all my images are now not being cached?
    Linda Lou

  22. damoncloudflare
    Member
    Posted 2 years ago #

    I don't *think* that will be an issue because it is only stopping the upload portion from the admin section of your site from being touched. Try turning on the caching option for the page rule to see if that still allows the smush.it plugin to work. It could be another feature, not caching, impacting whatever it was (go to edit rule & change it from bypass cache).

  23. lindaloustarr
    Member
    Posted 2 years ago #

    I just turned the page rule off - it was intermittenly causing some images not to load (absolutely cannot have that since my site is image intense & rich) - next time I smush I'll try it with caching to see if it changes behaviour. Until there is a permanent fix maybe to just do a page rule to smush then deactivate it . . .
    Linda Lou

  24. whitehallsd
    Member
    Posted 2 years ago #

    So Damon:

    Are you saying that you think it is the wp-admin/* page rule that is helping this? If so, I will try it with the wp-content/* page rule off to see if that is the case. I am fine with bypassing the the wp-admin folder.

    Will post whether or not it works if I take the content page rule out.

  25. damoncloudflare
    Member
    Posted 2 years ago #

    Hi,

    "Are you saying that you think it is the wp-admin/* page rule that is helping this?"

    We would generally recommend this (still beta testing). We've seen a number of issues with wp-admin, so better safe than sorry.

    Hi Linda,

    The page rule actually shouldn't impact the image loading. If you have something specific to share, please do (much easier to look at).

  26. B_Dark
    Member
    Posted 2 years ago #

    @damoncloudflare:
    1. I Have issues for both WP Smush.it & WP Smush.it NextGEN Gallery Integration
    2. W3 Total Cache
    3. WordPress 3.3.1
    i added the rules
    mysite.com/wp-content*& mysite.com/wp-admin* with security and perfomance off, Apps on and Custom caching: bybass cache...still have the same problem..:/ any idea for solution?!?!

    My issues started at 28 jan, some hours after that i activated my site on cloudflare, so definitely the problem coming from cloudflare

  27. whitehallsd
    Member
    Posted 2 years ago #

    Thanks Damon. The only rule that I have not is the wp-admin/* and it is working fine now.

  28. RadialBlur
    Member
    Posted 2 years ago #

  29. B_Dark
    Member
    Posted 2 years ago #

    @whitehallsd
    Can you help me? What did you do exactly and made ​​it?

  30. whitehallsd
    Member
    Posted 2 years ago #

    If you use cloudflare, follow the directions above from Damon for putting in a page rule to have your wp-admin bypass the cache.

    example: yourdomain.com/wp-admin/*

    I also made sure I cleared all of my caches including w3tc and my cloudflare cache.

    That seemed to do the trick for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic