WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Smush.it] Smushes exixting images but not newly uploaded (12 posts)

  1. the_loop
    Member
    Posted 4 years ago #

    Well, the plugin, after adding "www" to yahoo url in php file :D, does smush images yet present in media library.
    Then I made a proof uploading a new image, all OK

    But then on another image it did not smush it at uploading; so I clicked "smush.it now", but it returned:

    Could not /home/XXXX/public_html/wp-content/uploads find /home/XXXX/public_html/wp-content/uploads

    where XXXX is my ftp username.

    I checked file ownership, on new uploaded file the server gives 99:99, and permissions (644) given; i changed thewm to my username:group and to 666.

    Well nope, same strange error, just for that jpg...

    http://wordpress.org/extend/plugins/wp-smushit/

  2. Alex Dunae
    Member
    Posted 4 years ago #

    Did this ever happen again?

    Are there strange characters in the filename? The only thing that comes to mind is that I'm not escaping them properly.

  3. the_loop
    Member
    Posted 4 years ago #

    Mo, it didn't happen more...
    However strange, img's filename was not strange...

    Well, all ok now, thanks for your plugin! :D

  4. K0ZZM0
    Member
    Posted 3 years ago #

    I have the same problem...
    What can I do to resolve it?

  5. Hiranthi
    Member
    Posted 3 years ago #

    A client of mine is getting this notice too, not on all images but a few.

    No strange characters in the names btw.

  6. Alex Dunae
    Member
    Posted 3 years ago #

    Hi all -- there's a new version coming today, with changes to how paths and URLs are determined. Can you give it a try and let me know if this issue still persists?

  7. joymystic
    Member
    Posted 3 years ago #

    Hi Alex, I installed it tonight Dec. 16 2010 from both my WP plug-in dashboard as well as from here http://dialect.ca/code/wp-smushit/ but both failed to work. I get this message on both new and old images: [Smush.it error: Could not get the image] same as many did here for more than a year. Thanks for the support.

  8. Alex Dunae
    Member
    Posted 3 years ago #

    @joymystic are you using the standard wp-content/uploads/ directory structure or something else?

  9. joymystic
    Member
    Posted 3 years ago #

    I am using the standard one, Alex - /wp-content/uploads/

  10. Alex Dunae
    Member
    Posted 3 years ago #

    There must be a problem with the way file paths are translated in to URLs. I've just pushed out version 1.3.3 -- it adds a bit more info to the error message. If any of you want to give that a go and post back here with the error message I'd be grateful.

  11. joymystic
    Member
    Posted 3 years ago #

    Hi Alex,

    I just upgraded to Version 1.3.4 and it is finally working smoothly. I used to smush through yahoo's site before I upload. Your plugin even smushed those ealy uploaded images further. One Q: Is there an option to bulk smush or I have to individually do it? Thanks

  12. Alex Dunae
    Member
    Posted 3 years ago #

    There isn't a bulk smush option because I'm wary of overloading Yahoo!'s servers.

    From their terms 3 a):

    You will not use the service in a manner that exceeds reasonable request volume, constitutes excessive or abusive usage, as determined by Yahoo! in its sole discretion.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags