WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Smush.it] Error posting to Smush.it (39 posts)

  1. TRMW
    Member
    Posted 4 years ago #

    I just installed the plugin. When I attempt to smush a previously uploaded image, I get the following error:

    "Error posting to Smush.it"

    I checked and it doesn't look like the Smush.it site is down... any one else having this problem?

    http://wordpress.org/extend/plugins/wp-smushit/

  2. dreamwhisper
    Member
    Posted 4 years ago #

    Having the same problem here on WP 2.8. I also checked their site.

  3. micronox
    Member
    Posted 4 years ago #

    Same issue, happened when upgraded from 2.8.1 to 2.8.2

  4. dreamwhisper
    Member
    Posted 4 years ago #

    well, I'm having major issues on upgrading to 2.8.2. Good thing I only did it on 3 sites and not the whole lot.

    I did however edit my php.ini files to fopen on and that fixed the plugin.

  5. bsd13
    Member
    Posted 4 years ago #

    Having the same problem.

    "Error posting to Smush.it"

    Any updates?

  6. dreamwhisper
    Member
    Posted 4 years ago #

    Only that on a separate site, I also edited my php.ini file for fopen on and it isn't working on that site. So, I still have the problem.

  7. Navjot Singh
    Member
    Posted 4 years ago #

    Me too faced this problem on 2.8.2

  8. The Problem is, that the site smush.it redirect to the Yahoo service. There is no offical API at the moment. But I looked up the source of Yslow and found the 'new API'. I post the fix on my germany blog. There you can also download the plugin with the fix.

    I already informed the author, but he is currently busy.
    Questions can be asked in the blog.

  9. Alex Dunae
    Member
    Posted 4 years ago #

    Hi all,

    I have an updated version that uses the new smushit service, plus another little enhancement.

    However I'm attending the birth of my first child so you'll have to hang tight for a day or two.

    Thanks for your understanding.

  10. Alex Dunae
    Member
    Posted 4 years ago #

    A new version, 1.2.2, is up here: http://wordpress.org/extend/plugins/wp-smushit/

    Yahoo is being coy about opening up the API, and won't return my emails, so this plugin works now but I'm still searching for a permanent fix.

  11. roadchild
    Member
    Posted 4 years ago #

    Congrats on the new baby Alex!

  12. alexdunae, do you remove the fix? In 1.2.2 (and 1.2.3 ?) I can't see the new links.

  13. Alex Dunae
    Member
    Posted 4 years ago #

    I did remove the new theme smushing feature.

    It's not quite ready and that Yahoo URL fix was pretty urgent. Look for theme smushing in version 1.3.

  14. mhealy
    Member
    Posted 4 years ago #

    After upgrading to the latest version I'm no longer able to post via xmlrpc using Windows Live Writer. Any ideas how to resolve that?

  15. Alex Dunae
    Member
    Posted 4 years ago #

    @mhealy -- I pushed a new version of WP Smush.it out yesterday and it seems to play nicely with Windows Live Writer.

    Get in touch if you have any further issues with it: alex at dunae dot ca.

  16. rebus318
    Member
    Posted 4 years ago #

    Hey Alex! I am using the new version of smush.it (just downloaded it yesterday), and am using the latest WordPress edition. I am still getting the "Error Posting to smush.it" error. The smush.it site is not down. It's so cool that you created this... I hope I can get it to work... would be a great help to me.
    Thanks.
    Veggiescoop.com

  17. @rebus318
    Open the .php file and change the two lines to

    /**
     * Constants
     */
    
    define('SMUSHIT_REQ_URL', 'http://ws1.adq.ac4.yahoo.com/ysmush.it/ws.php?img=%s');
    
    define('SMUSHIT_BASE_URL', '');
  18. Alex Dunae
    Member
    Posted 4 years ago #

    ocean90 is correct. I'm pushing out a new version right now.

    Yahoo is making its Smush.it service a moving target...

  19. saymoon
    Member
    Posted 4 years ago #

    The API currently is not available for public use. We are working towards making this publicly accessible .

  20. shaneholden
    Member
    Posted 4 years ago #

    Does WP Smush.it smush the thumbnails, mediums, and large images if they're used as well if you are smushing already uploaded images? Or just the original size that's uploaded?

  21. Alex Dunae
    Member
    Posted 4 years ago #

    @shaneholden WP Smush.it optimizes all sizes, not just the originals.

  22. Alex Dunae
    Member
    Posted 4 years ago #

    Regarding saymoon's comment about the public API, Antonia at Yahoo just left me a comment saying that the API is supported.

  23. welshhuw
    Member
    Posted 4 years ago #

    hi,
    Im using version 1.2.6 and latest wordpress 2.8.6, and im gettin the error posting to smush.it message....?
    Any ideas how to get this to work - or a update soon??

  24. welshhuw, see here.

  25. welshhuw
    Member
    Posted 4 years ago #

    Ocean 90:- I have done that and still no joy.

    Although, on some of my wordpress sites, it works(intermitently) and on others i just get the error posting to to smush.it message every single time?

  26. welshhuw
    Member
    Posted 4 years ago #

    Sorry seems to be working this morning!

  27. centepines
    Member
    Posted 4 years ago #

    Can't get it to work. I followed all the steps, no success whatsoever. I guess it's just a question of luck.

  28. centepines
    Member
    Posted 4 years ago #

    Oh, I forgot to add, that I use Windows Live Writer to post in my blog (don't know if it has anything to do).

    Anyways, when I try to manually smush.it, I get the same response.

    I already tried Ocean's possible solution, no luck.

  29. rawarrior
    Member
    Posted 4 years ago #

    Akk.
    Same error message as others. Really hoping for an answer. Will try Ocean's fix.
    http://rawarrior.com

    ANY IDEAS?
    Not working.

  30. andyhowardidau
    Member
    Posted 4 years ago #

    I'm receiving the same error when attempting to smush and image that exists, and am receiving:

    Fatal error: Cannot redeclare class services_json in /nfs/c01/h14/mnt/14944/domains/crossfitpaleodiet.com/html/wp-includes/class-json.php on line 115

    ..when uploading a new image.

    WP 2.9.1

    Is there an incompatibility to be addressed? Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags