WordPress.org

Ready to get started?Download WordPress

Forums

WP SlimStat
[resolved] SQL STRAIN: Site loads incredibly slowly when SLIM Stat Activated (8 posts)

  1. benfranklin
    Member
    Posted 1 year ago #

    I was having some incredibly slow response time on my sites. Couldn't figure out why. Then I deactivated WP-Slimstat and presto, all my sites were fast again. I only have it installed on on site but it was bringing down load times of ALL database driven sites on my server. Restarting MySQL helped improve speed temporarily while it was active. Anyway have any similar experience like this? Anyone know average performance hit you take and ways to lessen strain. I really love the plugin, just need something that doesn't interfere with site speed.

    Thanks so much to anyone who replies.

    http://wordpress.org/extend/plugins/wp-slimstat/

  2. camu
    Member
    Plugin Author

    Posted 1 year ago #

    The average impact of WP SlimStat on my production sites (running on shared hostings) is 400 milliseconds, about half a second. Consider that my wp_slimstat table contains ~500k rows, so you can imagine why it takes a little while to update it. Do you have WP SlimStat indexes enabled or disabled? How many rows are we talking about? What kind of server are you using? WP SlimStat 2.8.3 already introduced some optimizations that speed-up the process of tracking a new pageview.

    If you have any ideas of how to further improve things, feel free to toss your two cents ;)

    Cheers,
    Camu

  3. michael walker
    Member
    Posted 1 year ago #

    Hi Ben,

    Did you ever make any progress with this? I am having this exact same problem. In my case, de-activating the plug-in made no difference - I had to actually delete it before things returned to normal.

  4. camu
    Member
    Plugin Author

    Posted 1 year ago #

    I think I found the problem, and I'm working on a fix. I'll keep you posted.

    Camu

  5. michael walker
    Member
    Posted 1 year ago #

    That's kind of you - thanks.

  6. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Version 2.8.4 includes a fix for this. Let me know if it works for you.

    Cheers,
    Camu.

    PS: a vote for my plugin would be a nice way to say thank you.

  7. michael walker
    Member
    Posted 1 year ago #

    Sorry for not responding earlier. Yes, the upgrade seems to have fixed it, for me, at least, so thanks.

  8. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Michael, a vote for my plugin would be a nice way to say thank you

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.