WordPress.org

Ready to get started?Download WordPress

Forums

WP SlimStat
[resolved] Permission Problem (14 posts)

  1. ronthai
    Member
    Posted 3 years ago #

    Hi Camu,

    I was trying to delete my own stats out of the database, before the blog goes life in a few days, but I run in to a "You do not have sufficient permissions to access this page." problem.

    Under the permissions tab I set in the first field my username (ygb001), the second I just left at read, the third I also put my username.

    I checked the forum and found something simular a month ago. I do not know if it is the same or maybe I am just doing it wrong.

    I am the only admin and nobody ever needs access to the admin or stats but me, so how do I configure that?

    Thank you and regards, Ron

    http://wordpress.org/extend/plugins/wp-slimstat/

  2. ronthai
    Member
    Posted 3 years ago #

    Little update,

    I remembered I have a plugin that allows emails to be used as username.

    I thought it would be a long shot, so I set my email address in the permission field. WOW, big mistake, all access denied everywhere.
    After save it changed the email address (removed the @ and .)

    Does not matter, I un-installed and installed again, so now the database is clean anyway. I set my own IP as ignore.

    Back to the problem my username ygb001 is not accepted somehow. Slimstats had me under that username in the stats, so it does reconize the username.

    Ok, that was the update, so back to the original problem.

    Thanks, Ron

  3. camu
    Member
    Plugin Author

    Posted 3 years ago #

    There was no need to uninstall, you could have edited that field in the database via phpmyadmin. Yes, WP SlimStat does not allow @ in the username, just like WordPress by default. It will strip out all the unaccepted characters.

    As for your problem, what happens if you leave that field empty, instead of specifying a username?

    Camu

  4. ronthai
    Member
    Posted 3 years ago #

    I get the same error message "You do not have sufficient permissions to access this page."
    That was why I put my username in there in the first place, because it says admins are not implicitly allowed.

    I have never seen or done anything with phpmyadmin. Is that a plugin or should I log in to my server and do something?
    It might be handy for the future.

    Thanks, Ron

  5. camu
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Ron,

    phpmyadmin is not a WordPress plugin, is a PHP environment to manage your database via a web interface. It's useful to edit your tables and data without having to use a command line interface.

    As for my plugin, you're right, it says that 'admins are not implicitly allowed', but that is only if the field is not empty. If empty, as stated, all are allowed (except subscribers).

    So, what is the USERNAME (not the alias) of your WordPress admin user? Is it ygb001 or admin? The one you type to log into your admin panels.

    Camu

  6. ronthai
    Member
    Posted 3 years ago #

    My username is ygb001 (I need to fill that in to get access to the admin)

    I also now deactivated the plugin "Email Users" which gives the possibility to use the email as login, but that made no changes.
    I checked and now can not login with my email only with username ygb001

    As mentioned if the field is empty or with only ygb001, in both cases I do not have permission.

    I will Google phpmyadmin and study it, just started with WordPress and databases (2 months), before I only did static html websites.

    Thanks, Ron

  7. camu
    Member
    Plugin Author

    Posted 3 years ago #

    This is weird, but it should work if you leave that field empty. Can I have admin access to your blog to see what the problem is? You can send the login info to

    http://www.duechiacchiere.it/contatto

    Camu

  8. ronthai
    Member
    Posted 3 years ago #

    Ok login set

  9. camu
    Member
    Plugin Author

    Posted 3 years ago #

    Do I have the URL of your website somewhere? I can't find it...

  10. ronthai
    Member
    Posted 3 years ago #

    Ok, check your mail

  11. ronthai
    Member
    Posted 3 years ago #

    Ok 3 emails sent, sorry

  12. ronthai
    Member
    Posted 3 years ago #

    When you have time to look at it,
    I just noticed that after the re-install human visit are no longer registered, also downloads are no longer registered.

    Accordeing to the Raw Data Tab there have been visits and I guess I am a human. Of course I deleted the filter I had for my IP.
    After that ygb001 and slim showed up.

    I do not know what happened but before the uninstall and re-install it registered all perfect and now no more.

    You can un-install it and re-install if needed not to worry about data since it is empty anyway.

    Hope it gets working before the Blog goes live in a few days.

    the user/pwd should also work to check the downloads

    Thanks, Ron

  13. ronthai
    Member
    Posted 3 years ago #

    I got it working again, so now it is registering all visits and downloads again. The problem was the Custom Path setting. Although I never changed anything there, when installing it put just mydomain/wp-slimstat, so I first just kept it empty, but that did not result in registering the hits/downloads.
    Now I just put the default path in there and now all hits/downloads are registering as they should.

    The original Permission problem still continues.

    Regards, Ron

  14. camu
    Member
    Plugin Author

    Posted 3 years ago #

    Okay, I was able to reproduce the issue in my local test environment. It is related to having SlimStat as a separate (stand alone) menu entry. I will have to look into this. A fix will be added to the next version of WP SlimStat.

    Thank you for finding this problem!

    Camu

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic