WordPress.org

Ready to get started?Download WordPress

Forums

WP Slimstat
[resolved] [Plugin: WP SlimStat] MaxMind Location Service Broken (23 posts)

  1. chinacarnella
    Member
    Posted 2 years ago #

    About a week ago, every time I clicked to see an IP address location through Slimstat/MaxMind, the MaxMind website box says "Query Limit Reached." It used to be 20 a day, and now it is Zero a day. Anybody have any idea what happened. I did not just upgrade wordpress. It's been upgraded for awhile, so that could not be the problem . . .Thank you.

    http://wordpress.org/extend/plugins/wp-slimstat/

  2. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Can you paste the URL you're trying to reach? It should look like

    http://www.maxmind.com/app/lookup_city?ips=2.37.76.178

    which works just fine for me. So they may have blocked your IP address for some reason. You should contact MaxMind and see if they can help. Don't forget that you can also configure WP SlimStat to use a different look-up service, if that one doesn't work for you!

    Camu

  3. camu
    Member
    Plugin Author

    Posted 2 years ago #

    PS: a vote for my plugin would be a nice way to say thank you!

  4. chinacarnella
    Member
    Posted 2 years ago #

    Hi Camu, Thanks for getting back to me. I did also contact Max Mind. Here is an example of a URL that doesn't go anywhere but to say "Query Limit Reached:"

    http://www.maxmind.com/app/lookup_city?ips=77.163.239.243

    It honestly does not matter which URL I try to click on, they all say the same thing. I can view these locations using Geobytes, for instance, so I'm not sure if it's that they're all blocking me . . . (??)

    Let me know what you think. In the meantime, I will search for a way to switch the IP locating company inside of Slimstat, plus where I can give you a star for your plug-in.

    Thanks!

  5. camu
    Member
    Plugin Author

    Posted 2 years ago #

    You can vote here

    http://wordpress.org/extend/plugins/wp-slimstat/

    As for the reason why you seem to reach your daily limit so quickly, Geobytes could be the answer. Don't forget that they also offer a paid premium subscription for those who need to perform more than 20 daily queries. You may want to look into that, too!

    Camu

  6. chinacarnella
    Member
    Posted 2 years ago #

    Hi Camu, I already gave you 5 stars :)

    I don't reach my limit "Quickly" I am not allowed to ever use the service - it Never gives me any info. I cannot perform even one query a day, and haven't been able to for a week or so now.

    What do you mean by "Geobytes may be your answer?"

    Thanks

  7. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you for your vote. About Geobytes, you may be using your 20 queries when you use their service. Or maybe Maxmind has banned your IP for some reason? Not sure...

    Let us know if you find out what the problem is, it could be useful info for people in the same situation ;)

    Camu

  8. chinacarnella
    Member
    Posted 2 years ago #

    OK, I'll wait to hear back from MaxMind. I was going to reinstall SlimStat as well. Thanks Camu.

  9. camu
    Member
    Plugin Author

    Posted 2 years ago #

    No, reinstalling SlimStat won't solve your problem. It's completely unrelated to what my plugin does.

    Camu

  10. pvwylick
    Member
    Posted 1 year ago #

    It seems Maxmind has changed its interface completely. Have a look at their new website.

  11. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Yes and I got a message from them saying that they don't offer the interactive ip location service (URL based) anymore. Time to find a new one, I guess...

  12. reefmowers
    Member
    Posted 1 year ago #

    Has anyone found a new service that we can replace the maxmind link with? I've tried a few things with no luck. Please let me know - Thank you.

  13. pvwylick
    Member
    Posted 1 year ago #

  14. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Nice one, pvwylick! I guess I will configure this one as the new default IP lookup service in my next release! Thank you.

  15. reefmowers
    Member
    Posted 1 year ago #

    That works pvwylick - Than you!

  16. scruffy1
    Member
    Posted 1 year ago #

    see my post about this, it appears maxmind have changed the code

  17. scruffy1
    Member
    Posted 1 year ago #

    didnt work for me

  18. camu
    Member
    Plugin Author

    Posted 1 year ago #

    I'm about to release the new version which fixes this issue.

  19. 1fullplate
    Member
    Posted 1 year ago #

    First, I want to thank you for a great plugin! And for the link above on how to vote for it. I really appreciate all your hard work on it, and more so all the effort you put in for "customer service" issues, which always says volumes!

    That being said, I'm still really discovering how to decipher all the great material you have given us! :) I'm pretty new to the world of WP.

    But I have noticed since the last update I haven't been able to use the geolocate with the new link. I tried a few different options with different lookups and I know I am not doing it right. I went back to an earlier post of yours listing the link for infosniper and pasted it just the way it is written but that isn't working either (as http://www.infosniper.net/geolocate-ip-addresses-urlparameter.php?lang=1 ).

    Can you tell me if this is still correct or if I need to input something different?

    Again, I really appreciate your help and the quality plugin! Thanks so much!

  20. pvwylick
    Member
    Posted 1 year ago #

    Try this in your Slimstat Viewer settings (IP lookup):
    http://www.infosniper.net/?ip_address=

    Works with me.

  21. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you, pvwylick for chiming in.

    Thank you 1fullplate, for your kind words. Please use the link here above and see if that works for you.

    Cheers
    Camu

  22. 1fullplate
    Member
    Posted 1 year ago #

    Thank you both so much! You're lifesavers!

    Now, as a mom, I want to remind you that taking a break from our sites today is important! This stuff can wait until later, or even tomorrow! :). (And yes, I have been telling myself this on and off for the last two hours! Lol =)

    Have a great Thanksgiving everyone!

  23. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Lol you're right. I've been doing the same all morning. Stuffed turkeys, we're comiiiiiing :)

    Happy Thanksgiving !

    Camu

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic