WordPress.org

Ready to get started?Download WordPress

Forums

Acunetix WP Security
[Plugin: WP Security Scan] Security Scan breaks Subscribe2 Mail Queue (5 posts)

  1. RickA99
    Member
    Posted 2 years ago #

    Mail Queue gave this error message: WPMQ Error. The wp_mail() function already exists. This is likely to be caused by another plugin.

    I discovered that it was WP Security Scan causing the problem. The error message went away as soon as I disabled Security Scan.

    The Mail Queue developer said this, "Having just had a look at the [WP Security Scan] code, it's because this plugin requires the WP core pluggable.php file on loading instead of using the action API. That means the pluggable code is called earlier than it should be."

    Link to Forum Post.

    Hope you guys fix this soon.

    http://wordpress.org/extend/plugins/wp-security-scan/

  2. WebsiteDefender
    Member
    Posted 2 years ago #

    Thanks Rick for letting us know about this issue! We'll look into it and see what we can do about it.

    Thank you for your feedback!

  3. WebsiteDefender
    Member
    Posted 2 years ago #

    Hello, Rick!

    I have installed the http://wordpress.org/extend/plugins/subscribe2/ plug-in but couldn't replicate that error...they both work just fine together...

    Edit:
    WP v3.2.1
    WP Security Scan v3.0.7
    Subscribe 2 v6.5

  4. RickA99
    Member
    Posted 2 years ago #

    The conflict is with the WP Mail Queue plugin. Info here.

    There are not many people who are going to use this plugin but since the developer claims that the conflict results from your not using the "action API", I think it would be worthwhile to check it out and see if you should be using it.

  5. WebsiteDefender
    Member
    Posted 2 years ago #

    Hi RickA99,

    Thank you for your suggestion. We will definitely check them out.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic