WordPress.org

Ready to get started?Download WordPress

Forums

WP RSS Multi Importer
[resolved] Can't add any feeds/categories (18 posts)

  1. danetidwell
    Member
    Posted 1 year ago #

    I'm on WordPress Multisite/Network. I've activated your plugin and can configure the options but the green buttons on both the RSS Feeds & Category Options don't do anything when they're clicked. It doesn't reload the page or anything, it is almost as if they're href=# or something.

    I'm using the latest version of Chrome on a Macbook.

    http://wordpress.org/extend/plugins/wp-rss-multi-importer/

  2. danetidwell
    Member
    Posted 1 year ago #

    It seems to conflict with a plugin called Recipress.

  3. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    Let me reproduce this on my local machine and get a fix for you. Thanks for bringing this to my attention.

    Allen

  4. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    ok..I've reproduced the problem...seems they are running a javascript function that is conflicting with a function on my plugin. I'll need to fix this. I'll let you know when I have something and I'll push an update. Thanks again.

  5. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    ok..the problem is that the author of Recipress put their JavaScript all through the site, not just on their admin page - but on all admin pages (bad practice). So, now I need to figure out how to get around their mistake.

  6. danetidwell
    Member
    Posted 1 year ago #

    Well - I'll just message them that their code is bad.

  7. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, they are just causing a JavaScript conflict with other plugins.

  8. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Ok..found the solution...go to line 200 in the wp-rss-multi-importer...change the line to

    add_action( 'init', 'wprssmi_register_scripts' );

    Let me know if this solves your problem, and if so, I'll update the plugin accordingly.

  9. PJJ
    Member
    Posted 1 year ago #

    Hi! I assume you've added this line to version 2.25 (since it is there :-) but lamentably it didn't solve this problem which I had, too. I have switched off all my plugins and then switched them on one by one, so soon I found the offensive one: HTML Editor Reloaded (there are complaints on its page that it is broken since WP 3.3 up, but I use 3.4.3 and it works alright.) WP RSS Multi Importer works with HTML Editor Reloaded switched off, stops to work with it switched on, and works again when I switch HTML Editor Reloaded off.

    Should you need any more info or want me to test a solution (which you'll hopefully want to come up with), just holler.

  10. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Hi PJJ
    Thanks...I'm going to add that plugin right now to my test site and see if it breaks my plugin...and then look for a work around (I've been putting my code into the init hook because some of these other plugins aren't restricting themselves to their own admin pages, but sticking them sitewide. Thanks for letting me know and I''ll post a response here and soon as I find something out.

    Actually, this program is doing the same thing as recipress...putting their javascript code in places they shouldn't. Terrible coding practice :(

    Allen

  11. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Ok..bottom line...that plugin has stuck their javascript on every page on the site, thus breaking other plugins. I might be able to fix this but it would be a lot easier to just delete their plugin and find another one who is written by somebody who is supporting it (since their support page has no responses from the plugin developer.

    Thanks again for bringing this to my attention.

  12. PJJ
    Member
    Posted 1 year ago #

    Thank you very much for your kind and quick reply!

    it would be a lot easier to just delete their plugin and find another one

    You are right; I decided to try AddQuicktag and it works fine with RSS Multi Importer, so I guess there's no need to worry about HTML Editor Reloaded anymore. Thanks a lot again!

    (I haven't complimented your plugin--nor voted for it--as in fact I haven't tried it out yet; hopefully I will.)

  13. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Hi PJJ
    Ok..I found the problem...their plugin is still a problem, BUT in the next version I've changed my javascript in such a way as to eliminate the conflict. If you want to give this a try right now, go into the main file and find the script called function wprssmi_register_scripts, delete that function and put this in instead:

    function wprssmi_register_scripts() {

    wp_enqueue_script( 'jquery' );

    wp_enqueue_script( 'add-remove', plugins_url( 'scripts/add-remove.js', __FILE__), array('jquery'), false, false);

    }

  14. PJJ
    Member
    Posted 1 year ago #

    Great, it did the trick! Thank you very much (even though I guess I'll stick to AddQuicktag)!

  15. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    great...and it would be very helpful to others if you spend a moment and rate my plugin by going to
    http://wordpress.org/extend/plugins/wp-rss-multi-importer/

    any rating helps (good or bad) to help others decide whether to give the plugin a try.

  16. louisaleontiades
    Member
    Posted 1 year ago #

    Hi,

    I'm pretty such there must be a conflict with another plugin I'm using for the site http://www.onlineknowledgepro.com - no feeds are loaded into posts and since I'm using this plugin on two other sites I'm pretty sure its set up correctly. Let me know if you need a login to look behind.

    Thanks

    Louisa

  17. Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    I think there may be a bug in the latest version if you have no categories set..if that's the case (you haven't added any categories for the feed to post) contact me at
    http://www.allenweiss.com/contact
    and I'll send you an update file that should solve this right now.

  18. louisaleontiades
    Member
    Posted 1 year ago #

    Hi

    I had added categories for feed to post - it was ALL >>> Founder's Blog. But in case I was mistaken, I also tested another category, set it and tried to fetch the feed.

    I also replaced the file that you sent. Still no joy. Thanks

    Louisa

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.