WordPress.org

Ready to get started?Download WordPress

Forums

WP RSS Aggregator
[resolved] Including RSS feed of host blog (20 posts)

  1. liz.morray@tamar.com
    Member
    Posted 1 year ago #

    Hi there,

    I'm trying to use your plugin to combine an external RSS feed with the posts for the blog that's hosting it. I appreciate that the plugin uses SimplePie and so can't access the loop of posts directly.

    I'm using http://domain.com/feed where the domain.com is that of the site I've installed the plugin on and it says this is an Invalid URL, when I use the W3 Validator is says it's valid, and I've successfully used it in RSS feed readers.

    If there's a solution that'd be super. If what I'm looking to do is impossible then it'd be good to know that too.
    Thanks!

    http://wordpress.org/extend/plugins/wp-rss-aggregator/

  2. liz.morray@tamar.com
    Member
    Posted 1 year ago #

    I've just installed this plugin on another site I'm working on. The feed URL I entered into the problem site (above) works on this second site. When I try to add the second site's own feed to the plugin I see the same "Invalid feed URL" alert so it's definitely a problem of adding the host site's feed in the plugin.

    Any work around would be welcome.

    Thanks.

  3. jeangalea
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    This is a strange issue you're having, not sure why you would have this problem because I've got it working well on a couple of sites in this way.

    For example take a look at http://www.wprssaggregator.com/demo/ and you will see that I have a feed from the host site working fine there.

    Make sure you also have the latest version of the plugin, although I think this would have worked on earlier versions too.

  4. xpil
    Member
    Posted 1 year ago #

    I am having exactly the same issue. Perfectly valid feeds (recognized by Firefox, feedly, digg and couple other well-known RSS engines) are not working with RSS Aggregator, giving the "Invalid feed URL" message. Any hints/ideas what I could do to get this fixed?

  5. jeangalea
    Member
    Plugin Author

    Posted 1 year ago #

    Please give me these valid feed URLs so I can test them out on my installation and find out what the issue is.

  6. xpil
    Member
    Posted 1 year ago #

    Jean,

    An example of such an url: http://toniedzikikraj.pl/feed/

    Another example: http://www.venividi.ie/channel.php

    Both above URLs work fine with other RSS programs/engines but not with WP RSS Aggregator.

  7. jeangalea
    Member
    Plugin Author

    Posted 1 year ago #

    Just tried both of them out and they worked perfectly. Can you make sure you are using the latest version of the plugin?

  8. xpil
    Member
    Posted 1 year ago #

    Jean,

    I am using version 3.2 of the plugin.

    Maybe it is incompatible with some other plugins? Just shooting in the dark, don't know much about WP internals.

  9. xpil
    Member
    Posted 1 year ago #

    Jean,

    I just tried the following:

    - Disabled ALL plugins but this one
    - Re-added the two URLs into the Aggregator

    Issue still exists so it looks like it is NOT related to other plugins getting into the way.

    I also tried this on another site of mine (with pure Wordpess, no other plugins, with Suffusion theme) and the issue was there, too.

    Is there any log file with detailed error messages that I could have a look at? Maybe this would shed some light...

  10. jeangalea
    Member
    Plugin Author

    Posted 1 year ago #

    The only thing I can think of is some difference in our server configuration. Have you tried it on a different host, or maybe a local server?

  11. jaywok
    Member
    Posted 1 year ago #

    I'm having the same issue. Things were working great. A few weeks ago all feeds started reporting 'invalid feed'. All feeds are valid, and I can use them in a browser, in other rss applications, etc.

    I noticed this is marked as resolved but am not seeing a resolution anywhere - am I missing something?

  12. jeangalea
    Member
    Plugin Author

    Posted 1 year ago #

    A new update should be out this week, check it then.

  13. jaywok
    Member
    Posted 1 year ago #

    Okay, thank you!

  14. jeangalea
    Member
    Plugin Author

    Posted 11 months ago #

    Did you get this sorted guys?

  15. xpil
    Member
    Posted 11 months ago #

    Nope. Still getting dupes every now and then.

  16. jeangalea
    Member
    Plugin Author

    Posted 11 months ago #

    Ok, this thread wasn't about duplicates though. Please open a new thread if you want us to look into a particular issue, we're very keen on perfecting the plugin.

  17. xpil
    Member
    Posted 11 months ago #

    Ahh, apologies, indeed, this thread is about some feeds not working.

    Well, I am still having this issue - some feeds (examples above) do not work with WP RSS Aggregator although they work perfectly with any other RSS reader (I tried Feedly, NewsBlur and MS Outlook - no issues). As mentioned above, I also tried them on a different hosting, different domain and with no other plugins / customizations. Same issue.

    Other feeds work flawlessly (except some rare duplicates) and I am generally happy with the plugin.

    If you want, I can spare some time to help you out debugging the issue. Just let me know.

  18. jeangalea
    Member
    Plugin Author

    Posted 11 months ago #

    Hi xpii,

    I tried both these feeds and they work fine with the latest version of the aggregator:

    An example of such an url: http://toniedzikikraj.pl/feed/

    Another example: http://www.venividi.ie/channel.php

  19. xpil
    Member
    Posted 11 months ago #

    Well, we are going to run in circles here. I already confirmed the issue three times. You claim it's been fixed. I still see an issue on my end (would you like a screenshot?), you are unable to reproduce it on your end.

    So it seems to me that it MUST be something with my Apache / WordPress / config / whatever, right?

    I guess I will simply ignore the issue for now. I am not expecting you to log in to my server and analyze its config. You have a life, too :)

    Maybe you could get me a version that produces some kind of a detailed debugging log so we could see exactly what happens here, step by step? Hm?

    Actually, a friend of mine will be setting up a brand new WordPress instance in the next couple of weeks. A new domain, different hosting. I'll ask him to install and test the plugin. We'll see.

    Thanks for all your responses so far. Truly appreciated.

  20. jeangalea
    Member
    Plugin Author

    Posted 11 months ago #

    Sounds like a plan!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.