WordPress.org

Ready to get started?Download WordPress

Forums

WP Retina 2x
[resolved] retinaimages.log without debug option checked (12 posts)

  1. mbecher
    Member
    Posted 2 years ago #

    Hi Jordy,

    first of all: thank for a great plugin. It does a really good job!
    I'm just having an issue with the log file (retinaimages.log), which is written although I don't have the debug option checked. Besides from eating up space and performance, I need to have my plugin directory writable, otherwise I'm just getting fopen errors and no images.
    Putting define('DEBUG', false); right on top of wr2x_retinaimages.php solves the issue for me, but I need to do this after each and every update of the plugin.

    I'd be fine with just setting the the DEBUG variable in wp-config.php, but that doesn't work either... Any ideas?

    Best -- marc (marcbecher.com)

    http://wordpress.org/extend/plugins/wp-retina-2x/

  2. Jordy Meow
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Marc,

    Thanks a lot for discovering this, that is an issue indeed and I already committed an update (a few seconds ago). The download of the current version will have this DEBUG disabled starting from now!

    I will update the plugin to a new version very soon so that the change is propagated to all the users.

    I'm glad you find this problem, thanks again!

  3. mbecher
    Member
    Posted 2 years ago #

    That's what I'd call a fast response. Awesome!
    Again: Great work on a superb plugin!

  4. Jordy Meow
    Member
    Plugin Author

    Posted 2 years ago #

    You're welcome ^^
    And please rate it if you appreciate my work on it (which was really intense during a few weeks, haha).

  5. mbecher
    Member
    Posted 1 year ago #

    Sorry, same problem on v0.4…

    And another question: It looks like @2x images are served only when on WIFI (at least on my phone, server side method). I'm totally fine with that approach, but didn't find that mentioned anywhere in the description, readme or FAQ. Would be worth to list that as a feature.
    Besides from that, I'd like to make an exception for my logo. So it would be served as @2x version regardless of the connection speed. Would you mind giving me a hint, on where to look at the code to make an exception for that file?

    regards -- marc

    (and yes, I gave you the full five stars for the plugin ;-)

  6. Jordy Meow
    Member
    Plugin Author

    Posted 1 year ago #

    Same problem on 0.4? Debug is TRUE for you? I checked and it's FALSE...

    This is something strange as well: especially with the server-side, it should ALWAYS be Retina images, WIFI or not! Except if the phone actually "acts" different depending on which is using (which could be clever actually), but I don't know about that. Anyways, it has nothing to do with the plugin at this point. With which phone are you experiencing it? Is there a way I can do this test as well?

  7. mbecher
    Member
    Posted 1 year ago #

    Hi Jordy,

    I just updated and all images were gone. Putting define('DEBUG', false); right on top of wr2x_retinaimages.php again solved the issue for me.

    I'm using mobile safari on an iphone4 (ios5.1.1). It's a simple matter of activating WIFI or deactivating it. Reload my homepage (marcbecher.com) and the logo on top is either blurred or crisp. I'm not aware of mobile safari acting diffently depending on the connection...

  8. Jordy Meow
    Member
    Plugin Author

    Posted 1 year ago #

    I am using the same one on the same phone but for me it's always crisp... did you have the chance to try with a different phone?

  9. mbecher
    Member
    Posted 1 year ago #

    Tested on another phone with the same results and after some fiddling it turned out to be the fault of the mobile proxy of my provider (german telekom)... Sorry!

  10. Jordy Meow
    Member
    Plugin Author

    Posted 1 year ago #

    How did you find this out? :)

  11. mbecher
    Member
    Posted 1 year ago #

    Well, there was not much left. Tried from two phones with the same result and I assumed you have a different provider...
    I googled around and found they have a settings page for mobile website (speed.t-mobile.de) where you can turn their compression off. After that everything is crisp again.

    To be honest, I'm totally pissed off. By default they put a lossy compression on my photos...

  12. Jordy Meow
    Member
    Plugin Author

    Posted 1 year ago #

    Amazing, I didn't knew the provider could do this! At the same time, they maybe want to provide a "faster" service by default... for most users it would be fine, but now with the new phones with nice and big screens it matters...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic