WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: WP-reCAPTCHA] Mailhide is not hiding mails (6 posts)

  1. zombaya
    Member
    Posted 5 years ago #

    I want to use this plugin to hide mails, since that is what you can do with it. But somehow it does not hide's my mails in posts or pages. I tried both buth it just doesn't do anything.

    I tried enabling the captcha on the registration-page and that worked fine.

    I also tried using different keys but still not working.

    The server uses php4 and has mcrypt enabled. I'm also using wordpress 2.8.
    I know the plugin says to be compatible up to 2.7.1 but on the developerswebsite the developer says it's also compatible with 2.8.

    Any suggestions?

    http://wordpress.org/extend/plugins/wp-recaptcha/

  2. zombaya
    Member
    Posted 5 years ago #

    Ok, I found out why it didn't work.

    If you disable "enable reCAPTCHA for comments", it doesn't work, which is not what I want.

    I want to be able to disable reCAPTCHA for comments and enable MailHide, which shouldn't be too much of a trouble.

    And now I am able! If you go to line 301 of wp-recaptcha.php and make this:

    if (($needed_capability && current_user_can($needed_capability))|| !$recaptcha_opt['re_comments']) {
    Into this:
    if (($needed_capability && current_user_can($needed_capability))) {

    Then you're ready to go.

  3. BlaenkDenum
    Member
    Posted 4 years ago #

    Hey zombaya, sorry for replying a little late. I will look into this soon, possibly tomorrow, and incorporate the fix for the next version. Thanks, I really appreciate your heads up.

  4. wracky
    Member
    Posted 4 years ago #

    Thanks for this.

    I wanted to do the same, and was surprised it didn't work.
    Your fix worked like a charm!

    Thanks again.

  5. mrgtb
    Member
    Posted 4 years ago #

    if (($needed_capability && current_user_can($needed_capability))|| !$recaptcha_opt['re_comments']) {

    ------

    You do realize with your fix "zombaya" above, that this line of code is displayed in 4 different places in the wp-recaptcha.php file. Yet you say it only needs editing in one place (on line 301). Can you be a little more clear on this.

    The code for me first starts on line (303), then is also displayed on these lines as well: (333, 447, 531)

    Here is more infomation:

    Line: 303
    if (($needed_capability && current_user_can($needed_capability)) || !$recaptcha_opt['re_comments']) {

    Line: 333
    if (($needed_capability && current_user_can($needed_capability)) || !$recaptcha_opt['re_comments']) {

    Line: 447
    if (($needed_capability && current_user_can($needed_capability)) || !$recaptcha_opt['re_comments'])

    Line: 531
    if (($needed_capability && current_user_can($needed_capability)) || !$recaptcha_opt['re_comments']

    Lines (447 and 531) are not exactly the same as the first two lines, but lines (303 and 333) are exactly the same. So do you still say edit only the first line only on line 303?

    Taking into account this extra information I've posted up?

  6. wracky
    Member
    Posted 4 years ago #

    I've just updated reCaptcha, and it seems that this fix is not yet enabled in the current release package.

    It would be nice if this could become the standard, since every time after an auto update, I now have to fix the file manually or my emails are out in the open :)

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic