WordPress.org

Ready to get started?Download WordPress

Forums

WP-reCAPTCHA
[resolved] "For security reasons, you must pass the remote ip to reCAPTCHA" (6 posts)

  1. gingerngo
    Member
    Posted 1 year ago #

    Hi,

    I recently updated my website to WP 3.4.1, and it seems the upgrade has affected the wp-recaptcha plugin. (It was working previously, before the upgrade.)

    I'm trying to register a test user on my site currently, but when I fill in the details and the captcha form, I get a message that says:

    "For security reasons, you must pass the remote ip to reCAPTCHA"

    Does anyone know how I can fix this, or what it means?

    Thanks.

    http://wordpress.org/extend/plugins/wp-recaptcha/

  2. Mvinoth
    Member
    Posted 1 year ago #

    Hi,

    same problem for me, yesterday i updated my website wordpress 3.2.1 to 3.4.1. today i enable recaptcha for registration form. i create one user for testing it show above error (For security reasons, you must pass the remote ip to reCAPTCHA). How i solve this error in wp 3.4.1. tell your suggestion

    Thanks

  3. itredsea
    Member
    Posted 1 year ago #

    Same problem here also ?
    "For security reasons, you must pass the remote ip to reCAPTCHA"

  4. Benjiwp
    Member
    Posted 1 year ago #

    Hello,

    in recaptcha.php line 328 :

    recaptcha_check_answer($this->options['private_key'], $_SERVER['REMOTEADDR']

    The right name is : REMOTE_ADDR

  5. odjinud
    Member
    Posted 1 year ago #

    Does not work on my site even after Bemjwp correction.

    I am getting error message: "Input error: Invalid referer"
    instead workingrecaptcha

  6. gingerngo
    Member
    Posted 11 months ago #

    Ah, thanks, Benjiwp! That totally worked!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.