WordPress.org

Ready to get started?Download WordPress

Forums

Artiss README Parser
[Plugin: WP README Parser] The plugin does not have a valid header. (4 posts)

  1. Gwyneth Llewelyn
    Member
    Posted 2 years ago #

    Under 3.1.2, when installing the plugin, I get a "The plugin does not have a valid header." error.

    This is what I get when automatically installing the plugin:

    Downloading install package from http://downloads.wordpress.org/plugin/wp-readme-parser.1.1.zip…
    
    Unpacking the package…
    
    Installing the plugin…
    
    Destination folder already exists. /home/gwyneth/gwynethllewelyn.net/wp-content/plugins/wp-readme-parser/
    
    Plugin install failed.

    Strange, isn't it?

    None of the suggestions/comments here apply to it: http://wordpress.org/support/topic/wordpress-28-the-plugin-does-not-have-a-valid-header?replies=24

    And clicking on the (inactive) plugin to activate it afterwards certainly worked for me, so I wonder if this was just a temporary glitch when unpacking it (after all, the ZIP file is created by WordPress.org) or some weirdness...

    http://wordpress.org/extend/plugins/wp-readme-parser/

  2. dartiss
    Member
    Plugin Author

    Posted 2 years ago #

    It's certainly odd. Looking around people up to the latest version of WP seem to have this problem and it usually appears to affect plugins that have the main file 2 folders deep - this doesn't apply in this case.

    You can read more about this problem here... http://mysillypointofview.wordpress.com/2010/05/27/fix-the-plugin-does-not-have-a-valid-header-error/

    Certainly the file isn't corrupt (just checked it!) so maybe you're right and it was a one off.

    David.

  3. dartiss
    Member
    Plugin Author

    Posted 2 years ago #

    BTW, I notice you're using the plugin on your personal site. IF you have any feedback or feature requests, please let me know.

    For example, I see the screenshots are spilling over because of their size - like WP does, would you like to see these limited in size?

    David.

  4. Gwyneth Llewelyn
    Member
    Posted 2 years ago #

    Hiya David :) Thanks for the replies; yes, it's quite odd, but (as you so well noticed), in spite of the error when installing, your plugin most certainly works.

    As for the screenshots, I guess I'm lazy, I could resize them with CSS, but sure, a setting on the shortcode options (e.g. maxwidth or something like that) would certainly be welcome!

    Thanks again for your plugin. It certainly makes me save precious time!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic