WordPress.org

Ready to get started?Download WordPress

Forums

WP-Polls
Script hangs when people click on 'vote' or 'view results' (12 posts)

  1. ogomez78
    Member
    Posted 2 years ago #

    The script that shows you the results when you vote or click on view results is hanging and all you get is a blank space. The effect is achieved via changing the opacity of the container to 0 while the script switches you to the results display but that never actually happens.

    See an example: http://www.aclu-de.org, the 'what do you think?' section at the bottom.

    http://wordpress.org/extend/plugins/wp-polls/

  2. onepack
    Member
    Posted 2 years ago #

    Same here

  3. onepack
    Member
    Posted 2 years ago #

    I rolled back to the 2.5 version to make it work again in wordpress 3.3.2

  4. Lester Chan
    Member
    Plugin Author

    Posted 2 years ago #

    Is there anyway I can reproduce it? I can't seem to reproduce the problem on my end.

    Also does it work with the twentyeleven theme?

  5. onepack
    Member
    Posted 2 years ago #

    Hi Lester, Sorry for my late response, I just was too busy. I will check if it works with twentyeleven today and post my results here.

  6. onepack
    Member
    Posted 2 years ago #

    I installed the latest version again but the weird thing is that in IE 9 every vote will result in a reload of the whole frontpage where the poll results should appear. Chrome is also broken after voting. It will show a big blank screen. Only Firefox seems to work now.

  7. pajaro
    Member
    Posted 2 years ago #

    Hi Lester & OGomez78, I was able to refresh OGomez78 website http://www.aclu-de.org after voting (nothing happen after I voted) as the results where displayed. I am using Chrome (Google). Hope that helps...

  8. pajaro
    Member
    Posted 2 years ago #

    Hi Lester & OGomez78, I was able to refresh OGomez78 website http://www.aclu-de.org after voting (nothing happen after I voted) as the results where displayed. I am using Chrome (Google). Hope that helps...

  9. ogomez78
    Member
    Posted 2 years ago #

    Hi guys

    I just tried it on a mac w/safari and It's not working.

    Thanks for following up on this.

  10. mishari
    Member
    Posted 2 years ago #

    Hi,

    I'm getting the same symptoms as well on http://www.travel-impact-newswire.com for some strange reason it insists on using https for the ajax-admin.php rather than plain http, I wonder if this has something to do with it.

  11. Lester Chan
    Member
    Plugin Author

    Posted 2 years ago #

  12. nayeema_afrin
    Member
    Posted 1 year ago #

    I have just solved the problem.

    When there is get_footer(); , wp poll is not working i.e you can not vote.

    To solve it add wp_footer() instead of get_footer(). Now the voting system will work, but you can not see any footer.

    To solve this problem, just add include('footr.php'); below wp_footer();.

    So the final solution is to keep
    <?php
    wp_footer();
    include('footer.php');
    ?>

    instead of <?php get_footer(); ?>

    Hope this will help you.

    Thanks,
    Nayeema

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags