WordPress.org

Ready to get started?Download WordPress

Forums

WP-Polls
Failed to Verify referrer (11 posts)

  1. factor2k
    Member
    Posted 2 years ago #

    Every time I try to vote I get "Failed to Verify referrer"... Any ideas how to solve this?

    http://wordpress.org/extend/plugins/wp-polls/

  2. factor2k
    Member
    Posted 2 years ago #

    Still getting "Failed To Verify Referrer" after voting... Anyone?

  3. wx1
    Member
    Posted 2 years ago #

    Me too, same problem.
    Probably caused, in my case, by Hyper Cache, deactivating the plugin (Hyper Cache) everything works fine with wp-polls. But before the last update, wp-polls and Hyper Cache coexisted without problems, now it seems that I'll have to give up to one of them.

  4. factor2k
    Member
    Posted 2 years ago #

    I do not have hyper cache =\.

  5. wx1
    Member
    Posted 2 years ago #

    Hi again fac7orx,
    I don't know what version you have installed, but I'm making a test downgrading the plugin version from 2.63 --> 2.62

  6. factor2k
    Member
    Posted 2 years ago #

    I believe tried both of those versions, but yeah let me know how it goes.

  7. wx1
    Member
    Posted 2 years ago #

    Ok, test done. The version 2.62 works fine just like before the 2.63 update.
    I hope that this thread catches the eye of the developer soon.

  8. saaraan
    Member
    Posted 2 years ago #

    It's not recommended but my site uses cache files.. so wrapping this php code with comment /* -- */in wp-polls.php, solved in my case.

    /*
    if(!check_ajax_referer('poll_'.$poll_id.'-nonce', 'poll_'.$poll_id.'_nonce', false))
    		{
    			_e('Failed To Verify Referrer', 'wp-polls');
    			exit();
    		}
    */
  9. bkjproductions
    Member
    Posted 1 year ago #

    saaraan's fix worked for me! Thanks! I posted a note back at Lester Chan's site:
    http://lesterchan.net/wordpress/2012/06/05/ajax-not-working-for-wp-email-wp-polls-wp-postratings-or-wp-postviews/

  10. Lester Chan
    Member
    Plugin Author

    Posted 1 year ago #

  11. DoubleSixx
    Member
    Posted 1 year ago #

    @Lester Chan

    W3 Total Cache was updated a few days ago (don't remember when exactly) and there's no cache for JS/CSS in the Minify section.

    Any suggestions ?

    Thanx in advance, great plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.