WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP-Polls] Compatibility with 2.9.* (20 posts)

  1. greps
    Member
    Posted 4 years ago #

    Hello,

    According to the plugin page, it works or 15 people and doesn't work for 11. Is there any official word on the plugin's compatibility with WordPress 2.9.*?

    I plan to install this plugin on a very busy site and don't want to take any chances :)

    Thanks in advance.

    http://wordpress.org/extend/plugins/wp-polls/

  2. Thomas
    Member
    Posted 4 years ago #

    Why dont give it a try, it's just to remove it if you encounter any problems?!

    It works fine for me, however it did not work together with the Google Map plugin.

    Thomas

  3. ozai
    Member
    Posted 4 years ago #

    incompatible Greps
    I regret the fact of upgrading to 2.9.1 really..
    the cons are that the plugin builder will not offer any more upgrades to the plugin.. which is real sad..

    I've installed it two days ago.. and I've been trying to make it work in 2.9.1 ever since. the loading cursor keeps spinning with no results..
    some people suggested fixing some code line in footer.php which I did, but didn't help much.

  4. Lester Chan
    Member
    Posted 4 years ago #

    Check your permissions.

    Ensure ALL files in /wp-content/ are CHMOD to 644 and ALL folders to 755.

    And try to see if it works on the default theme.

  5. webposer
    Member
    Posted 4 years ago #

    I'm using 2.9.2 and with a custom theme, the plugin does not work. I've switched to the default theme and the plugin works. I'm curious if anyone knows what is different? I've taken pieces like the default footer.php and replaced my custom themed footer.php - that isn't it.

    Any advice? I'd really like to use this plugin.

  6. bananajota
    Member
    Posted 4 years ago #

    Hello GamerZ, i have your great plugin, and works good until WP last version.
    With 2.9.1 works fine (with header and footer codes)
    but with 2.9.2 is not working anymore.

    It's do nothing when you cast a vote.
    I tryed to change themes, put another code, put same again, uninstalled from polls uninstall, and reinstalled, etc. and nothing happened. And my files are chmod 644 and my folders 755.

    Any Clue?
    my site is http://www.diegocosta.com.ar

  7. Joco1114
    Member
    Posted 4 years ago #

    I got "Please choose a valid poll answer." on WP2.9.2. Any idea? Please help!

  8. aparentdesign
    Member
    Posted 4 years ago #

    Upon voting, poll puts answer in another nested wp-poll wrapper in 2.9.2 and most recent plugin. I went back to 2.31.

  9. Lester Chan
    Member
    Posted 4 years ago #

    In Poll Templates in WP-Admin, restore all templates to default

  10. DaveClapp
    Member
    Posted 4 years ago #

    I had this same problem with WordPress 2.9.2 on a custom theme. The custom theme was missing the wp_head() and wp_footer functions. Once I placed those functions into the theme's header.php and footer.php the wp-polls work Perfectly.

  11. burns777
    Member
    Posted 4 years ago #

    I can confirm that adding <?php wp_footer(); ?> to the footer.php and <?php wp_header(); ?> to the header.php made it work for me in 2.9.2! Thanks DaveClapp

  12. priyankanm
    Member
    Posted 4 years ago #

    Although it is directly not related to the version 2.9.2 of wordpress but in my case the plugin was not at all working previously (loading forever) still after adding <?php wp_footer(); ?> <?php wp_header(); ?> and changing folders permission to 755 and files to 644 as suggested by some.

    After testing the polls with the default theme, I found out that this must be some problem with my custom theme files only. By checking the function.php I saw that I had used a deregister styles code in my theme function similar to this below:

    add_action( 'wp_print_styles', 'my_deregister_styles', 100 );
    function my_deregister_styles() {
    	wp_deregister_style( 'wp-polls' );
    	wp_deregister_style( 'thickbox' );
    }

    So now when I removed wp_deregister_style( 'wp-polls' ); from that, the polls are working perfectly just as it was before. Hope this helps someone else.

  13. priyankanm
    Member
    Posted 4 years ago #

    Oh sorry I had also removed the
    if ( !is_admin() ) wp_deregister_script('jquery');
    code from the same function.php which I forgot to mention in the previous comment.

  14. alexlan
    Member
    Posted 4 years ago #

    WP version: 2.9.2
    WP-polls version: 2.50
    Issue: impossible to click 'Vote' button under FireFox, clicking 'Vote' button causes JS error under IE7, IE8.
    Theme: custom

    Solution:
    I checked if it is working in the default WP theme - and it worked properly. Then I checked if I had <?php wp_footer(); ?> in the footer.php and <?php wp_header(); ?> in the header.php - I had them both in my custom theme. Then based on the suggestions from priyankanm I started looking for all 'junk' in my custom theme's PHP files. After 2 hours of research I found, that if my custom Footer.php is replaced with the default Footer.php (from Default WP theme), the problem is solved and 'Vote' button worked.

    As I hadn't more time for this, I just replaced my custom footer.php with the default one, and the only thing I modified in it was adding a one <div> block with footer image in it.

    Here is a list of things that I removed from the footer, maybe some of them caused the issue:

    <?php wp_get_archives('title_li=&type=postbypost&limit=5'); ?>
    ...
    <?php if (function_exists('mdv_recent_comments')) { mdv_recent_comments(5); } ?>
    ...
    <?php wp_cumulus_insert(); ?>
    ...

    Thanks to everyone.

  15. melstan1
    Member
    Posted 4 years ago #

    Great thread. Any tips for inserting a poll directly into a post? I only see instructions for poll pages and sidebars in the wp-polls documentation.

  16. quanin
    Member
    Posted 4 years ago #

    WordPress 2.9.2, latest WP-Polls version. I'm trying to imbed a poll within a post using: [poll id="n"] where according to the list of polls, n is the ID of the one I'm looking for. Plugin comes back with "there are no valid polls", even though the poll is open. What am I not doing correctly?

  17. horria
    Member
    Posted 4 years ago #

    yes, I was too missing <?php wp_footer(); ?> :) thanks

  18. azjudy
    Member
    Posted 4 years ago #

    I've been wrestling with wp polls - trying to get it to work in Thesis 1.7. I can create a poll and have it show up on a page or in the sidebar widget. However, the vote button will not work from either place. See: Baby Girl McCarthy sidebar.

    At first I thought it may be a plugin conflict, but when I change to the default theme, the vote button works fine. So there has to be something unique to the Thesis Theme that is preventing it from working.

    I tried entering php code in the header.php and footer.php, however, doing so broke the site - (perhaps I put them somewhere I shouldn't have).

    Permissions have been set according to recommendations in this thread. Any other ideas of a work-around?

  19. emilbus20
    Member
    Posted 4 years ago #

    Just ran into this issue. When I would click on View Results in FF I would see nothing, but in IE it worked fine.

    I added <?php wp_footer(); ?> and all is well.

    Lester you the man I use a lot of your plugins.
    Thanks!

  20. Lester Chan
    Member
    Posted 4 years ago #

    I am guessing it maybe conflicting with some plugins JS.. Try disabling all the plugins except wp-polls. Because if it works in IE, I can't figure out why it will not work in FF

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags