WordPress.org

Ready to get started?Download WordPress

Forums

WP-Piwik
[resolved] Two problems... (5 posts)

  1. eldad@segaltec.co.il
    Member
    Posted 1 year ago #

    [ Moderator Note: Please post code or markup snippets between backticks or use the code button. ]

    Hello,
    On the mail App page inside wordpress
    "Thanks for using WP-Piwik!
    An error occured: You can't access this resource as it requires an view access for at least one website. [Support]
    Auto site configuration is enabled.
    Tracking code insertion is disabled"

    I have inserted the "Before the </body> tag on your index.html or index.php file include the following code:

    // <!-- Piwik -->
    <script type="text/javascript">
    var pkBaseURL = (("https:" == document.location.protocol) ? "http://www.MYSITE/counter/" : "http://MYSITE/counter/");
    document.write(unescape("%3Cscript src='" + pkBaseURL + "piwik.js' type='text/javascript'%3E%3C/script%3E"));
    </script><script type="text/javascript">
    try {
    var piwikTracker = Piwik.getTracker(pkBaseURL + "piwik.php", 1);
    piwikTracker.trackPageView();
    piwikTracker.enableLinkTracking();
    } catch( err ) {}
    </script><noscript><p><img src="http://www.MYSITE/counter/piwik.php?idsite=1" style="border:0" alt=""/></p></noscript>
    <!-- End Piwik Tag -->

    Under FOOTER.PHP That's is the only file i have found /body

    in the Piwik settings, problem with "check url and auth token"
    I have inserted in the REST url: http://www.MYSITE/counter/index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday#module=Dashboard&action=embeddedIndex&idSite=1&period=day&date=yesterday&idDashboard=1

    And the Token i took from the API page and paste...

    Please help me to fix this issue :)
    Thanks :)
    Eldad

    http://wordpress.org/extend/plugins/wp-piwik/

  2. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    The URL ist your Piwik's dashboard URL. Try just " http://www.MYSITE/counter/" - it should work fine :)

    If your template uses the wp_footer() function, you have not to add your tracking code manually, because WP-Piwik will offer you to add it automatically.

  3. eldad@segaltec.co.il
    Member
    Posted 1 year ago #

    Thank you for the fast reply
    I have changed the link but i still see a message "An error occured: Piwik did not answer. Please check your entered Piwik URL. [Support]
    but when i login to MYSITE/counter i see the website visits...
    on the "settings page"
    An error occured: Please check URL and auth token. You need at least view access to one site. [Support]
    I have checked the "Auto config" box as well...

    I tried to check the Automatic wp_footer() function, but didn't see and code in the box... still saved and nothing has change in the message that error
    Thanks again

  4. eldad@segaltec.co.il
    Member
    Posted 1 year ago #

    OK!

    I have changed the Auth token again (it has new characters)

    Now its all fine :)

    Thank you for the great support

  5. braekling
    Member
    Plugin Author

    Posted 1 year ago #

    Allright, fine :)

    At least please keep sure you use a manually added tracking code OR WP-Piwik's "add tracking code" option. If you are not sure about this, please have a look a your site's source code. The tracking code should only appear once.

    Have fun & success with (WP-)Piwik!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.