WordPress.org

Ready to get started?Download WordPress

Forums

WP-Piwik
[resolved] Piwik error: Please specify a value for 'idSite'. (10 posts)

  1. cedric.charles
    Member
    Posted 2 years ago #

    Hi !

    I've install the WP-Piwik plugin on my multi site but I have a problem...
    When I go for the first time on the WP-Piwik dashboard of a subsite, I have this message inside the boxes :

    "Piwik error: Please specify a value for 'idSite'."

    I need to click on the link to the site (front end) or/and click on the "Change" button to see the stats.

    Any ideas ?
    Thanks

    http://wordpress.org/extend/plugins/wp-piwik/

  2. csigncsign
    Member
    Posted 2 years ago #

    oh yes, I have the same problem, see the WP-Piwik-forum:

    http://peepbo.de/board/viewtopic.php?f=4&t=21

  3. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    Hi there.

    WP-Piwik will create a new website in Piwik not until it was triggered the first time. So WP-Piwik doesn't know a site's Piwik ID if it was never opened before.

    I will keep this in mind and try to avoid this behaviour (e.g. by creating a site on the first call of it's stats also).

  4. csigncsign
    Member
    Posted 2 years ago #

    Thanks for that hint, that solved my problem concerning this.
    My site was in maintenance mode and so has no statistics yet.
    I deleted for testing the admin filter and then wp-piwik works again like a charm and the error has disappeared.

  5. webraket
    Member
    Posted 2 years ago #

    WP-Piwik will create a new website in Piwik

    Are you sure this works with a "view access only" token_auth (as suggested in wp-piwik settings)?

    I have 20.000+ blogs running and no siteid's are added to piwik.
    I don't know if this plugin can handle such ammounts anyway...

  6. webraket
    Member
    Posted 2 years ago #

    The code looks great on first inspection (can't wait to use it).
    However the select-list on super_admin screen fails with SharDB.
    Even if it worked it will take too many resources with large networks.

    $aryBlogs = $wpdb->get_results($wpdb->prepare('SELECT blog_id FROM '.$wpdb->prefix.'blogs ORDER BY blog_id'));
    foreach ($aryBlogs as $aryBlog){
    	$objBlog = get_blog_details($aryBlog->blog_id, true);
    	$aryOptions[$objBlog->blogname.'#'.$objBlog->blog_id] = '<option value="'.$objBlog->blog_id.'"'.($blog_id == $objBlog->blog_id?' selected="selected"':'').'>'.$objBlog->blogname.'</option>'."\n";
    }
    ksort($aryOptions);
    foreach ($aryOptions as $strOption) echo $strOption;

    You should use $wpdb->blogs instead of $wpdb->prefix.'blogs' to support SharDB/HyperDB/MultiDB etc.

    Also please add a global setting to disable sitewide stats for super_admins since 20.000+ blogs in a select-list is trouble.
    I can login to piwik itself (alternatively Analytics) to get a sitewide overview, and only need per-site stats for my users.

    Thanks.

  7. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    WP-Piwik should work fine even with thousands of blogs because it doesn't manage the blogs itself. It tries to get a blog's Piwik ID by it's URL. If the blog isn't found, WP-Piwik will ask Piwik to create a new ID.

    Of course the super admin stats select box is not a perfect solution if you are using WP-Piwik in a very big netowrk. This was mentioned before and will be fixed by paging or a similar solution.

    I'll have a look at your database issue and will consider this in 0.9.2.

    Of course WP-Piwik can create new site IDs only if the token grants write access. "at least view access" describes the requirements to run WP-Piwik principally. I'll think about a more precise description.

  8. cedric.charles
    Member
    Posted 2 years ago #

    Hi and Thanks,

    So if I have understood, if have to open the site first to have access to the site stats ? When could we expect to solve this problem ?

  9. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, you have to visiti your blog, because site creation/detection is not triggered before. (But in most cases there should'nt be any stats before a site is visited first. ;-))

    A have a lot of "To-Do"s, but I think I can consider to solve this in 0.9.2, too.

  10. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    This should be solved in 0.9.2 (release soon).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags