WordPress.org

Ready to get started?Download WordPress

Forums

WP-Piwik
[resolved] network activate doesn't work w/ 0.9 (23 posts)

  1. TheDudeAbides
    Member
    Posted 2 years ago #

    I upgraded to 0.9 on my wordpress network that was using network activate(so I wouldn't have to individually activate each site), and the plugin has stopped working in that mode. The settings and charts no longer appear on the dashboard. Disabling network activate and activating manually still works though.

    http://wordpress.org/extend/plugins/wp-piwik/

  2. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    If WP-Piwik 0.9.0 is network activated, its settings will be shown at your Network Admin menu (My Sites -> Network Admin). Please check this, the settings are not shown at all Site Admin menus anymore.

  3. TheDudeAbides
    Member
    Posted 2 years ago #

    I did that but it only shows the one piwik url for the root site and I can't change it for the others.

  4. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    You are talking about the blog URLs, aren't you? (WP-Piwik supports just a single Piwik URL in network mode.)

    In network mode WP-Piwik configures your blogs automatically by their URLs and also fetches the individual tracking code for each blog. (Showing the root site's tracking code only is confusing... I'll change this.)

  5. TheDudeAbides
    Member
    Posted 2 years ago #

    Okay it seems to be working now. It was just a little confusing what was happening at first. Perhaps some additional details on the network page would be beneficial.

  6. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    I enabled a lot of WP-Piwik features for network mode ("WPMU-Piwik") which were only available in "single blog mode" before. But I didn't think about new descriptions to avoid confusions.

    0.9.1 will contain more detail information regarding to network users.

  7. trau.kainehm
    Member
    Posted 2 years ago #

    Oh yes, it works.

    But you have to network activate the plugin and set the auth token once again. Two easy steps, but if don't know about it, you'll miss some days in you tracking.

  8. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    Please keep in mind multisite support is still experimental. If you like to use experimental software in a "real world" environment, you should test its behaviour after each update.

    Anyhow the auth token must not go missing after updating. Didn't WP-Piwik tell you to check your settings after updating?

    @TheDudeAbides: Did you also have to set your auth token again?

  9. TheDudeAbides
    Member
    Posted 2 years ago #

    I did need to set my piwik url and token again.

    Perhaps "multsite mode" should be an option after being network activated? Normally when I network activate a plugin the functionality stays the same and it just activates on all blogs by default.

  10. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, I'll have a look at this. Secondary I'll add a warning message if token and URL aren't set.

    There are three different ways to activate plugins in a blog network:

    1. Site Specific Plugins: Just add the plugin. Each user can activate and use this plugin on his own.

    2. Network Plugins: This is a global activated plugin working for all blogs automatically. Activation and configuration are done by the network admin, apart from that the functionality stays the same.

    3. Must-Use Plugins: Auto-activate the plugin for all blogs, configuration is done individually (as you described). To use WP-Piwik as Must-Use Plugin you have to create a single file in mu-plugins including mu-plugins/wp-piwik/wp-piwik.php.

  11. demilio
    Member
    Posted 2 years ago #

    Why is'nt the WP-Piwik link showing for the sub-admins anymore? It's a great stats for each admin, but after I upgraded to 0.9 it's gone for all the membrs. Superadmin can still see the link in each blog-admin but it's not there for each admin.

    Hope you will add the link again as this is a good and working plugin for me and my users :)

    PS: Dont know if this is relatet to the question from TheDudeAbides... but hope it can solve something for someone

  12. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    If you are just missing the stats link (Dashboard -> WP-Piwik), please check if admins are allowed to see stats:

    My Sites -> Network Admin -> Settings -> WP-Piwik -> "Display to:"

    If you are missing the settings link (Settings -> WP-Piwik), enable WP-Piwik as a normal plugin (not as network plugin). So each blog admin can configure WP-Piwik on his own.

  13. demilio
    Member
    Posted 2 years ago #

    It doesnt work. I "solved it" by going back to the older versio and updating some of the files manually. It works for now.

    I really hope you add this support in the be t version. I got 200 bloggers so it would be hard to maintain the support if everyone shoud do this for them selvs hehe.

    Its a great plugin btw :)

  14. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    Hi demilio.

    Sorry for answering late.

    Can you tell me which files (and how) you updated manually?

    You are using WP-Piwik as a "Network Activated Plugin", aren't you?

  15. demilio
    Member
    Posted 2 years ago #

    I'm no pro so i cant remember what i did, but i know that the previus version had the link in the user dashboard. So what i did was downgrade wp-piwik to the prev version and then just manually upgrade to 0.9 all the files except the main plugin file... Wp-piwik.php i think?

    It may be that i did some changes to that file too but cant rmemeber. I know i compared the main file from 0.9 and 0.89 and did some small editing but didnt really know what i did.

    I use the wpmu with piwik yes. And all the blogger got a wp-piwik link in the dashboard now with stats. Hope you find it out bevause people love the stats.

    Sorry for my bad english..

  16. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    Please tell me some details about your WP config:

    - You are running a WordPress blog network (multisite/WPMU), aren't you?
    - Is WP-Piwik activated as a Network Plugin or as a Site Specific Plugin?

  17. demilio
    Member
    Posted 2 years ago #

    I'm running wpmu and have activated wp-piwik as network not single site

  18. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    Alright, and it works fine - tracking code is added, stats are shown to you, etc. - but your bloggers can't see their own stats link (Dashboard->WP-Piwik)?

    Can you tell me which roles are chosen at the "display to:" setting? Maybe I can try similar settings here to get an idea why this is not working for you.

  19. demilio
    Member
    Posted 2 years ago #

    No, they can see theyre link after I added did the changes i did to the main plugin-file.

    send me your e-mail and I can send you a zip with the files :)

  20. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, but this was your issue before your changes ;) Did you try the current 0.9.1?

    You can send me your changed file to webmaster -at- braekling -dot- de, so I can check the changes you've done.

    But please tell me your "display to:" configuration also.

  21. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you very much. I had a look at your files but you just hardcoded some settings & changed the stats link's name.

    Can you backup your current WP-Piwik files and try 0.9.1?

  22. demilio
    Member
    Posted 2 years ago #

    I just tried it after your e-mail and it didn't work. The plugin works but the sub-users still dont see the stats-link in their dashboard.

    remember that the main file is from 0.89 version. It works in 0.89 so what I did was just update to 0.90 and then I added the main file (wp-piwik.php) from the 0.89 version to the plugins-folder. Then I think i did some small changes to it to make it work together.

  23. braekling
    Member
    Plugin Author

    Posted 2 years ago #

    You also tried to enable all roles shown at "display to"?

    You just changed the link's name from "WP-Piwik" to "Statistikk". The access management does not differ between your wp-piwik.php and the 0.9.0/1 wp-piwik.php

    The hardcoded settings are overwritten by the settings in your database... but you didn't change anything regarding the access management. You added the base configuration, enabled "add_tracking_code" and changed the "piwik_shortcut" default value. ("Piwik shortcut" activates a simple link from the stats and the dashboard widget to Piwik itself.)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags