WordPress.org

Ready to get started?Download WordPress

Forums

WP-Piwik
[resolved] Multisite Update Procedure (13 posts)

  1. kremalicious
    Member
    Posted 3 years ago #

    Problem is, I upgraded via the Backend to 0.8.5 and changed wp-piwik_wpmu immediately to true. After that the plugin created new entries in Piwik for all sites in the network again instead of picking up the existing entries created with 0.8.4. Users now aren't able to see their statistics before the upgrade in the Backend and WP-Piwik puts in the tracking code for the newly created sites.

    So are there any infos on the correct update procedure for a multisite installation so it picks up the already created sites instead of creating double entries?

    Nevertheless a great plugin, thanks for the effort!

    http://wordpress.org/extend/plugins/wp-piwik/

  2. braekling
    Member
    Plugin Author

    Posted 3 years ago #

    Hm, strange. I'll try to reproduce this in my multisite test environment. Normally it should work as you did the update procedure.

  3. kremalicious
    Member
    Posted 3 years ago #

    Alright, thanks. In my other test environment the same happened. I think the steps to reproduce are these:

    1. install & activate 0.8.4 of your plugin with multisite settings, visit some sites to populate the entries in Piwik
    2. update to 0.8.5 in the Backend, afterwards change wp-piwik_wpmu via the Plugin editor
    3. visit some sites, in my environments this created the sites in Piwik again, with new IDs and such

    I started using the plugin beginning with 0.8.4 so I don't know if this is a problem with this update only or a general update problem. Just before the plugin update I updated Piwik itself too, from 1.1.1 to 1.2.1 but this didn't double the entries.

    While I guess there's no way to combine all the double entries it would be nice to know this won't be happening with the next update again. So I'm thankful for any hints on how to avoid this :-)

  4. braekling
    Member
    Plugin Author

    Posted 3 years ago #

    0.8.5 brought just some minor fixes which shouldn't affect the multisite feature. Maybe it is a problem regarding to the new configuration handling since 0.8.4.

    Currently I have no idea, my test environment works fine. But I'll try to figure this out, of course.

  5. gormer
    Member
    Posted 3 years ago #

    I can also verify this issue. After doing an upgrade here all my sites are a big mess now. I have some that constantly creates new instances of sites and some that is not updated. I will see if I can find the source of the error.

    What happens is that new instances of wp-piwik_settings gets generated even though there are already one present. M

  6. gormer
    Member
    Posted 3 years ago #

    So I tried to downgrade to 0.8.3 and I still get some duplicates when I delete the _settings option in the database: which I found weird. I don't really get whats wrong and can't do so much testing on the live site.

  7. braekling
    Member
    Plugin Author

    Posted 3 years ago #

    Can you try the current development version, please?
    http://downloads.wordpress.org/plugin/wp-piwik.zip

    I'm sure this will fix the issue.

  8. UnPointZero
    Member
    Posted 3 years ago #

    Hi !

    Same problem here, I've updated to 0.8.5 and some sites get the same ID ( see http://www.slchauffage.fr & http://www.almec.fr :) ).
    Development version doesn't fix this problem...

    Btw, nice plugin just waiting for debugging :).

    Edit : Ok cleaned my WP database ( deleted all wpmu-piwik entry ) and it seems to be OK !

    Reporting in few days to tell you if everything runs fine :)

    C ya !

  9. braekling
    Member
    Plugin Author

    Posted 3 years ago #

    Some sites with same IDs? Sounds like another problem. Please tell me if this happens again.

    But I hope the current dev version fixes the "multiple ID" problem.

  10. kremalicious
    Member
    Posted 3 years ago #

    Can you try the current development version, please?

    Tested, looks smooth and seeing no double entries being created after the update. Of course it now uses the newly created entries from the last update only. But I guess there's no way to merge them back somehow, right?

  11. braekling
    Member
    Plugin Author

    Posted 3 years ago #

    Thank you very much. There will be an update on saturday.

    But I don't know how to merge the double entries... maybe it is easy to solve by a small script. I'll check this soon.

  12. braekling
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry for the delay caused by the devil of a toothache. I'll try to finish the update this weekend.

  13. braekling
    Member
    Plugin Author

    Posted 3 years ago #

    Fixed in 0.8.6.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags