WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP-Piwik] getting fatal error on installation (3 posts)

  1. michapixel
    Member
    Posted 4 years ago #

    i know it sounds silly, but i'm getting the above described error.

    Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in [...]/blog/wp-content/plugins/wp-piwik/wp-piwik.php on line 32

    I'm not a php expert but i guess it's because the server i'm trying to run this plugin on still is php4 only :-(

    do you think this can be fixed (by me) ? i really like to run this as a plugin for a customer. i know piwik-code can be inserted by hand and stats can then be pulled of by a stanalone app. but this process hurts a little bit.

    http://wordpress.org/extend/plugins/wp-piwik/

  2. braekling
    Member
    Posted 4 years ago #

    Hi michapixel,

    yes, it's because you are using PHP4. It should be a hard piece of work to remove the whole PHP5 stuff... and it has do be done again after each update.

    Isn't it possible to upgrade to PHP5? The official PHP4 support ended at 2007-12-31 and it wasn't updated since august 2008.

    I'm sorry to tell you I won't provide a PHP4-compatible version of WP-Piwik in future.

  3. michapixel
    Member
    Posted 4 years ago #

    It's okay. It was not my decision to use this provider (which is very well aware of that problem, but is unable / unwilling to change anything about that)

    so i guess i'm going plan b ;-) hack in the code by hand and provide the client some links / software

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags