WordPress.org

Ready to get started?Download WordPress

Forums

WP Photo Album Plus
[resolved] - Slideshow not working. (18 posts)

  1. trulyandy
    Member
    Posted 3 years ago #

    WP Photo Album Plus Version 2.4.4, I have successfully created 2 Photo Albums and assigned a number of photos to each, which I can browse in the Plugin Dashboard.

    The 2 Album previews post to my Page fine. http://tierradesuenoslodge.com/our-place/rainforest-photo-gallery/

    Clicking "View Photos" loads a new page with the all of the Album's thumbnails, and when you click on a thumbnail a new page w/ the Slideshow controls loads, however, no images show up on the Slideshow page.

    Similarly, clicking "View Slideshow" under the Album Previewloads a new page w/ the Slideshow controls, but no images show up.

    Both WordPress and the Plugin are the most current versions, and I just deleted and re-installed the Plugin to no avail.

    thanks!

  2. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    Your theme does not load the required javascript file.
    What is your theme? If you made or modified it, please post the contents of header.php here.

  3. trulyandy
    Member
    Posted 3 years ago #

    ahhh, your response led me to the solution, which was pretty simple, of course.

    my header file was missing <?php wp_head();?> before </head>

    I added that and the slideshow now works.

    thanks!

  4. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    That's what i expected.

  5. robahas
    Member
    Posted 3 years ago #

    Hi, I suspect I have a similar same issue. I'm getting nothing on a theme I created from scratch, using the command <?php wppa_albums(1, 'slide'); ?>.

    Here's my header:

    '<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
    <html>
    <head>
    <title>Expressions of Brooklyn</title>
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    <link rel="stylesheet" type="text/css" href="http://fonts.googleapis.com/css?family=Tangerine">
    </head>'

  6. robahas
    Member
    Posted 3 years ago #

    BTW, here's the site: http://www.intuito.biz/brooklyn/

  7. robahas
    Member
    Posted 3 years ago #

    Fixed by adding wp_head(); before closing </head>.

  8. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    Nice you found the same fix for the same problem as trulyandy did...

  9. mrturtle
    Member
    Posted 3 years ago #

    Hi Guys

    I have had 2.5 working fine for http://www.jbhomestyling.com

    But the client went and upgraded TO 3.0 and it seems that I'm having the same issue as trulyandy first had on this thread.

    I have loaded WP PHOTO ALBUM and it's got it working, but I'd obviously like to us PLUS.

    PLEASE! Here's the header...

    <?php
    /**
    * @package WordPress
    * @subpackage QualiFire
    */

    global $qualifire_options, $style, $current_slider;
    // get the current color scheme subdirectory
    $style = ( $qualifire_options['color_scheme'] ) ? "style{$qualifire_options['color_scheme']}": "style1";

    $logo_img_url = ( $qualifire_options['custom_logo_img'] ) ? $qualifire_options['custom_logo_img'] : get_bloginfo('template_url').'/styles/'.$style.'/images/logo.png';
    $logo_width = $qualifire_options['logo_width'];
    $logo_height = $qualifire_options['logo_height'];
    $current_slider = $qualifire_options['current_slider'];

    ?>

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>>

    <head profile="http://gmpg.org/xfn/11">
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    <meta name="google-site-verification" content="tgLxJ_Hq5dKc9B4Ac4ohARS_CuFYHTwZFBf69IQNPj4" />
    <title><?php wp_title('«', true, 'right'); ?> <?php bloginfo('name'); ?></title>
    <meta name="description" content="We are a Poole based renovations and restorations company. We offer high class, professional service in decorating, building and repairs." />

    <meta name="keywords" content="Painter, decorator, Bournemouth, Poole, Renovations, restorations, carpenter, builder, tiler, kitchen, bathrooms" />

    <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />

    <?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>

    <!--[if IE 6]>
    <script type="text/javascript" src="<?php bloginfo('template_url'); ?>/scripts/DD_belatedPNG_0.0.8a-min.js"></script>
    <script type="text/javascript">
    // <![CDATA[
    DD_belatedPNG.fix('.pngfix, img, #home-page-content li, #page-content li, #bottom li, #footer li, #recentcomments li span');
    // ]]>
    </script>
    <![endif]-->
    <?php wp_head();?>

    <!--[if lte IE 8]>
    <link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/styles/common-css/ie-all.css" media="screen" type="text/css" />
    <![endif]-->
    <!--[if lte IE 7]>
    <link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/styles/common-css/ie6-7.css" media="screen" type="text/css" />
    <![endif]-->
    <!--[if IE 6]>
    <link rel="stylesheet" href="<?php bloginfo('template_url'); ?>/styles/common-css/ie6.css" media="screen" type="text/css" />
    <style type="text/css">
    body{ behavior: url("<?php bloginfo('template_directory'); ?>/scripts/csshover3.htc"); }
    </style>
    <![endif]-->

    </head>

  10. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    Your header looks ok, js and css is koaded.
    I would like to investigate on this, but you should have wppa+ 3.0.0 installed then.
    If it is not possible to have that for a day or so, you can go back to version 2.5:

    Click the 'other versions' link on the plugins homepage and install the version you want manually:

    download, unzip, ftp.

  11. mrturtle
    Member
    Posted 3 years ago #

    Hi opajaap

    The current version is 2.5 as this was the last one that worked, so I downgraded via deleting the 3.0 version and reloading the 2.5 version.

    I can upgrade if you think this would help.

    How can you help me as I'm totally stuck!

    Many thanks

    M

  12. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    Are we still talking about this site?
    http://www.jbhomestyling.com/gallery-of-work/?album=2&photo=89
    Here you are not running wppa+ 2.5
    Note: you can NOT have both wppa and wppa+ activated at the same time!

    I prefer you go to 3.0.0 and have me have a look into it

  13. mrturtle
    Member
    Posted 3 years ago #

    Hi

    I deleted the 3.0. and then installed 2.5. It said it was 2.5 in the plugin page of wordpress. I have now upgraded to 3.0.

    Can you look for me know?

    Thanks friend

    M

  14. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    You still have wp-photo-album activated and wp-photo-album-plus not

  15. mrturtle
    Member
    Posted 3 years ago #

    Hi opajaap

    I have now made the PLUS live.

    M

  16. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    Your jquery library is outdated.
    Is your wp installation up-to-date?

    You might try unchecking 'Fadein after fadeout'. That will at least resolve the error why it stops. But there may be other problems.

  17. mrturtle
    Member
    Posted 3 years ago #

    Hi

    The 'fade in' was the issue. Now working.

    Thank you very very much for your help.

    M

  18. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 3 years ago #

    You have a commercial theme named qualifire that distributes the jQuery library. You payed at least $35 for that theme.

    Either you do not get regular updates from those boys, (the jQuery rev is 1.3.2, while the current native wp jQuery rev is 1.4.4), or they distribute obsolete software. I can not see what their current jQuery rev is since i am not going to pay $35 for a download. As far as i can see is your wp version 3.1, so that's ok.

    If your theme is up-to-date, you should complain at the qualifiers.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic