WordPress.org

Ready to get started?Download WordPress

Forums

WP Photo Album Plus
[resolved] Image size issue in IE (15 posts)

  1. mattrheault
    Member
    Posted 2 years ago #

    Hello,

    We are using the most recent release of your gallery, and it works perfect except that the fullsize image is squished in IE. I'm assuming this is an issue in the javascript because the actual inline css for the width is coming out at around 20px in IE where it should be around 400px.

    Could not debug, any help would be much appreciated.

    Here is a screenshot of the issue.
    http://i53.tinypic.com/2llbx34.jpg

    http://wordpress.org/extend/plugins/wp-photo-album-plus/

  2. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 2 years ago #

    Please supply a link to a page that shows the problem. A screenshot is of no use. Did you try compatibility mode on or just off? Most of the times that helps for this type of problems.

  3. mattrheault
    Member
    Posted 2 years ago #

    Where can I turn on compatibility mode?

  4. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 2 years ago #

    The classical menu tab extra

  5. mattrheault
    Member
    Posted 2 years ago #

    Sorry but where is the classical menu tab extra? I'm not seeing any of this in the WPPA+ settings.

  6. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 2 years ago #

    In Windows Internet Explorer, at the right hand side, just left to the blue questionmark there is a menu Extra, the 9th item in this menu (of which i am not sure of the name as i only have the dutch version) enables you to switch on the menu bar (first item). This shows the normal (classical) menu bar. On that bar press Extra, on that menu press the 10th item: Compatibilitymode (?). By switching this on or off, you can switch between two sets of IE bugs. For one site it should be on, the other site it should be off, but nobody seems to know why what and when..., just try.

    This is for IE 8.0

  7. mattrheault
    Member
    Posted 2 years ago #

    This does fix it. But I need a better solution that does not require whoever is viewing the website to go into their settings and turn on compatibility mode.

  8. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 2 years ago #

    You are most welcome to analyze the cause of this issue. If it turns out to be fixable in wppa+ i am most willing to implemnt such.

    As my sites do not exhibit this behaviour, i can not reproduce it and therefor not analize it. To my opinion it is a theme issue rather than a wppa+ issue.

  9. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 2 years ago #

    Fixed in 4.0.4

  10. mellojoe
    Member
    Posted 2 years ago #

    In version 4.0.10, the issue is back. In IE 8, any pictures in landscape mode are stretched (currently displaying at 640x562). Yet, when I switch on "compatability mode" the images are displayed correctly (640x480).

    Is there a change from 4.0.4 to 4.0.10 that caused this error to come back?

    THANKS!

  11. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 2 years ago #

    A link would be usefull

  12. mellojoe
    Member
    Posted 2 years ago #

  13. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 2 years ago #

    What are your settings of: Table I items 1,2,3,4,5 and Table IV items 1 and 2 (if any) ?

  14. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 2 years ago #

    Your problem is not the height but the width.

    In your themes style.css it reads (line 741):

    #content img {
        height: auto;
        margin: 0;
        max-width: 640px;
        width: auto;
    }

    Change max-width: 460px; into max-width: 800px; or remove the line.
    That will fix your problem.

  15. mellojoe
    Member
    Posted 2 years ago #

    Thank you!!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic