WordPress.org

Ready to get started?Download WordPress

Forums

WP Photo Album Plus
How to enable lightbox? I seriously can't figure it out (18 posts)

  1. defunctlife
    Member
    Posted 1 year ago #

    Hello,

    I'm using 4.5.7.

    I am trying to figure out how to enable lightbox, here is what I've done so far:

    Table IX (Miscellaneous): Item 9a (Lightbox keyname) I set this to wppa.

    Table VI (Links): Item 2a,b,c,d I set Thumbnail to link to lightbox.

    It just opens the image directly instead of in any kind of lightbox.

    I checked the docs included with the plugin but I can't find anything.

    Thank you

    http://wordpress.org/extend/plugins/wp-photo-album-plus/

  2. defunctlife
    Member
    Posted 1 year ago #

    I'd like to add I don't have any visible javascript errors. Also looking at the source it seems the wppaLightBox = ""; variable is empty under "WPPA+ Runtime parameters".

    I hacked wppa-non-admin.php to force it to be wppa but it still doesn't work.

    Please let me know what I can try to get it working.

    Thank you

  3. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    A link please

  4. defunctlife
    Member
    Posted 1 year ago #

  5. tuleki
    Member
    Posted 1 year ago #

    I have a related issue with lightbox. It doesn't seem to activate properly when surfing the photo albums.

    Pressing an album link - and then click on a photo, I only get the basic image path on the server. It opens up the jpg as it is. But if I hit refresh in the album, lightbox works. What gives?

  6. defunctlife
    Member
    Posted 1 year ago #

    Hi opajaap,

    Did you have a chance to check the site out?

    Thanks

  7. defunctlife
    Member
    Posted 1 year ago #

    Hi again Opajaap,

    I've tried a number of things so far, so if you have any suggestions that would be great.

    I reset all the settings, added in wppa again to the Lightbox keyname setting, followed the warnings/error messages your plugin generated to disable things that weren't compatible with lightbox, but it still doesn't work. I even reverted to the twentyten theme, but it still functions the same.

    No JS errors to follow or anything. Using the debug setting didn't give me any useful information.

    Please advise.

  8. defunctlife
    Member
    Posted 1 year ago #

    Well here is how I got it working:

    1) Installed lightbox plus: http://wordpress.org/extend/plugins/lightbox-plus/
    2) Set Table IX 9a to: lightbox
    3) Set Table VI 2 to: (Link type) lightbox

    Made sure the plugin didn't have any warnings/errors (had to disable a few things as recommended).

    Now it's good. Confusing, as I understood lightbox was included with this plugin.

  9. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    If you install the current version (4.6) lightbox is included in the plugin. You only need to set the lightbox keyname to wppa IX-A6

  10. dsyd
    Member
    Posted 1 year ago #

    Hi Opajaap, I couldn't figure it out either. I had IX-A6 set to wppa as it was by default. Nothing was happening - when I clicked the image I just got taken directly to the file. I checked to confirm that the wppa.js file was being included.

    Using Lightbox Plus worked for me. But I don't know how to get it showing the description for the image inside the Lightbox - is that possible?

    Thanks for sharing the plugin.

  11. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    @dsyd:
    If you supply a link to the site and configure the wppa lightbox - so i can see it myself - i can analyze what is wrong

  12. dsyd
    Member
    Posted 1 year ago #

    Thanks Opajaap, that would be great if you could take a look. I've disabled Lightbox Plus and set the IX-A6 setting back to wppa.

    The site's here: http://progress.earthsharing.co.uk/ and the Photo of the Day widget about half way down the page on the right where it says "Archival Images".

  13. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    Are there any security settings on the site that may cause this? The browser (Firefox) jumps into quirks mode. I am not an expert on that.
    The wppa+ config looks good.

  14. dsyd
    Member
    Posted 1 year ago #

    Hi Opajaap,
    That's strange as I have "<!DOCTYPE html>" at the top of the page source and I had thought that HTML5 got rid of quirks mode. When I type this into the Firebug console:

    javascript:m=(document.compatMode=='CSS1Compat')?'Standards':'Quirks';window.alert('You are in ' + m + ' mode.');

    ...it tells me I'm in standards mode. Same in Chrome and IE when I type it in the address bar.

    I'm not sure what I should be looking for in terms of security settings. AFAIK, I've not done anything out of the ordinary.

    Thanks again for your help!

  15. dsyd
    Member
    Posted 1 year ago #

    BTW that's with Firefox 13.0.1, Chrome 19.0.1084.56 m, and IE 9.0.8112.16421.

  16. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    I use firefox 13.0.1 and firebug. The web developer toolbar displays 3 green checkmarks/red crosses at the extreme right hand side: compliance mode, css error status, js error status. The first (compliance mode is red cross: quirks mode).

  17. dsyd
    Member
    Posted 1 year ago #

    Strange, I see standards mode. Hovering my mouse over the three boxes I see this (from left to right):

    1. "Standards Compliance Mode" (Green tick)
    2. "CSS Error: Error in parsing value for 'filter'. Declaration dropped." (Red cross)
    3. "No JavaScript Errors" (Green tick)

    This is with version 1.1.9 of the Web Developer toolbar.

  18. dsyd
    Member
    Posted 1 year ago #

    Opajaap,
    Just to let you know I figured out what was wrong.

    I had VI-8 ("Slideshow fullsize link") set to "No link at all" and it needed to be set to "Lightbox". Didn't think to check that at first as I'm not using the Slideshow widget, I'm using the Photo of the Day widget.

    Might help to have a note on that explaining that it also affects the POTD widget. Thanks again for your help and for the plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic